SAPHIRE 8 Basics

An Introduction to Probabilistic Risk Assessment via the Systems Analysis Program for Hands-On Integrated Reliability Evaluations (SAPHIRE) Software

Curtis Smith
James Knudsen
Kurt Vedros
Michael Calley
Kellie Kvarfordt
Ted Wood

Idaho National Laboratory

February 2016
SAPPHIRE – The “Big Picture”

Develop Project Models
(logic and data) Produce Current Case Data Perform Analysis Final Product

Build Fault Trees (Section 6)

Build Event Trees (Section 5)

Modify Basic Events (Section 7)
- Probabilities
- Frequencies
- Uncertainties
- Descriptions

Generate Probabilities (Sections 2 and 7)

Link Event Trees (Section 11)

Fault Tree Analysis (Sections 8-10 and 17)

Report Results
- Graphical Output (Section 5 and 6)
- Basic Events (Section 7 and 16)
- Fault Trees (Section 15 and 16)
- Sequences (Section 15 and 16)

Sequence Analysis (Sections 12-14 and 17)

NOTICE

This report was prepared as an account of work sponsored by an agency of the United States Government. Neither the United States Government nor any agency thereof, nor any of their employees, makes any warranty, express or implied, or assumes any legal liability or responsibility for any third party's use, or the results of such use, of any information, apparatus, product or process disclosed in this report, or represents that its use by such third party would not infringe privately owned rights. The views expressed in this report are not necessarily those of the U.S. Nuclear Regulatory Commission.
# CONTENTS

| 1 | INTRODUCTION ........................................................................................................... 1 |
|   | 1.1. OVERVIEW OF SAPHIRE BASICS COURSE MATERIAL ........................................ 2 |
|   | 1.2. SAPHIRE - WHAT IS IT AND WHAT CAN IT DO? .................................................. 3 |
|   | 1.3. THE CLASS WORKBOOK ...................................................................................... 4 |
|   | 1.4. OVERVIEW OF PRA ........................................................................................... 4 |
|   | 1.5. DEFINITIONS ................................................................................................... 5 |
|   | 1.6. MAJOR STEPS "NUREG-1150 TYPE" PRA PROCESS ........................................... 7 |
|   | 1.7. ACCIDENT SEQUENCE QUANTIFICATION STEPS ............................................... 10 |
|   | 1.8. INSTALLATION OF SAPHIRE ............................................................................. 10 |
|   | 1.9. SAPHIRE USER SETTINGS ................................................................................ 11 |
| 2 | DATABASE CONCEPTS ............................................................................................... 19 |
|   | 2.1. SAPHIRE PROJECTS .......................................................................................... 20 |
|   | 2.2. NOMINAL CASE VERSUS CURRENT CASE DATA ................................................ 23 |
|   | 2.3. GENERATING EVENT DATA ................................................................................ 24 |
|   | 2.4. RULES FOR CREATING AND USING CHANGE SETS ......................................... 25 |
|   | 2.5. NOMINAL CASE UPDATE .................................................................................. 27 |
| 3 | MAIN MENU TOOLBAR ............................................................................................ 29 |
|   | 3.1. FILE .................................................................................................................. 29 |
|   | 3.2. VIEW ................................................................................................................ 30 |
|   | 3.3. BOOKMARKS .................................................................................................... 32 |
|   | 3.4. PUBLISH .......................................................................................................... 34 |
|   | 3.5. PROJECT ......................................................................................................... 35 |
|   | 3.6. TOOLS ............................................................................................................. 41 |
|   | 3.7. HELP .............................................................................................................. 45 |
| 4 | MODEL EDITING ......................................................................................................... 47 |
|   | 4.1. SAPHIRE MODEL DEVELOPMENT AREA ......................................................... 47 |
|   | 4.2. LISTS PANEL .................................................................................................. 48 |
| 5 | BUILDING EVENT TREES .......................................................................................... 51 |
|   | 5.1. EVENT TREE DEVELOPMENT .......................................................................... 52 |
|   | 5.2. EVENT TREE TERMINOLOGY ........................................................................... 53 |
|   | 5.3. SAPHIRE EVENT TREE CONVENTIONS .......................................................... 53 |
|   | 5.4. BEGINNING AN EVENT TREE EDITING SESSION .......................................... 54 |
|   | 5.5. INSERTING TOP EVENTS .................................................................................. 55 |
|   | 5.6. MODIFYING TOP EVENTS ................................................................................ 56 |
|   | 5.7. EDITING EVENT TREE BRANCHES ................................................................... 57 |
|   | 5.8. EDITING SEQUENCE/END STATE INFORMATION ............................................. 58 |
|   | 5.9. EDITING THE VISUAL DISPLAY OF EVENT TREES ......................................... 59 |
|   | 5.10. ENDING THE EVENT TREE EDITING SESSION .............................................. 60 |
|   | 5.11. EXAMPLE EVENT TREE .................................................................................. 61 |
5.12. PRINTING EVENT TREE GRAPHICS ........................................................................................................ 61

6 | BUILDING FAULT TREES .............................................................................................................................. 63
6.1. FAULT TREE DEVELOPMENT ................................................................................................................... 64
6.2. SAPHIRE FAULT TREE TERMINOLOGY ................................................................................................... 65
6.3. SAPHIRE FAULT TREE CONVENTIONS ................................................................................................. 65
6.4. BASIC EVENT SYMBOLS ........................................................................................................................... 66
6.5. LOGIC GATE SYMBOLS .............................................................................................................................. 67
6.6. BEGINNING A FAULT TREE EDITING SESSION ..................................................................................... 70
6.7. FAULT TREE GATES AND BASIC EVENTS ............................................................................................ 71
6.8. FAULT TREE MAIN MENU ...................................................................................................................... 73
6.9. ZOOMING ................................................................................................................................................ 75
6.10. ENDING THE FAULT TREE EDITING SESSION .................................................................................... 75
6.11. PRINTING FAULT TREE GRAPHICS ....................................................................................................... 76

7 | BASIC EVENT EDITING .................................................................................................................................... 79
7.1. BASIC EVENT TERMINOLOGY .................................................................................................................. 79
7.2. MODIFY BASIC EVENTS ............................................................................................................................ 79
7.3. EDIT BASIC EVENT SCREEN .................................................................................................................... 80
7.4. BASIC EVENT FAILURE MODEL ............................................................................................................... 81
7.5. BASIC EVENT ATTRIBUTES ..................................................................................................................... 89
7.6. BASIC EVENT APPLICABILITY ................................................................................................................ 91
7.7. BASIC EVENT NOTES ............................................................................................................................... 92
7.8. BASIC EVENT SUMMARY ........................................................................................................................ 93
7.9. EDITING A BASIC EVENT ......................................................................................................................... 94

8 | GENERATING FAULT TREE CUT SETS ........................................................................................................ 99
8.1. PREREQUISITES FOR GENERATING FAULT TREE CUT SETS ................................................................ 100
8.2. MENUS AND OPTIONS FOR FAULT TREE CUT SET GENERATION .................................................. 101

9 | FAULT TREE UNCERTAINTY ANALYSIS .................................................................................................... 107
9.1. FAULT TREE UNCERTAINTY ANALYSIS ............................................................................................... 108
9.2. UNCERTAINTY DISTRIBUTIONS FOR BASIC EVENTS ........................................................................ 109
9.3. MENUS AND OPTIONS FOR PERFORMING FAULT TREE UNCERTAINTY ANALYSIS ..................... 110

10 | FAULT TREE IMPORTANCE ANALYSIS ..................................................................................................... 113
10.1. FAULT TREE IMPORTANCE MEASURES ............................................................................................. 113
10.2. DEFINITIONS OF THE IMPORTANCE MEASURES ............................................................................. 114
10.3. IMPORTANCE MENUS AND OPTIONS ................................................................................................. 116

11 | LINKING EVENT TREE SEQUENCES ......................................................................................................... 119
11.1. LINKING EVENT TREES ......................................................................................................................... 119
11.2. UNLINKING EVENT TREES .................................................................................................................... 121

12 | GENERATING EVENT TREE CUT SETS ..................................................................................................... 123
12.1. PREREQUISITES FOR GENERATING EVENT TREE CUT SETS ............................................................ 123
### Table of Contents

12.2. **Menus and Options for Event Tree Cut Set Generation** ......................................................... 123
12.3. **Additional Event Tree Sequence Cut Sets Analysis Features** .................................................. 128

| 13 | **Sequence Uncertainty Analysis** ................................................................. 129 |
| 13.1. **Menus and Options for Performing Sequence Uncertainty Analysis** ................................. 129 |
| 13.2. **Uncertainty Calculation Values** ................................................................. 131 |
| 13.3. **Uncertainty Results** .................................................................................. 131 |

| 14 | **Sequence Importance Analysis** ................................................................. 133 |

| 15 | **Viewing Cut Sets** .................................................................................. 137 |
| 15.1. **The View Cut Sets Option** ........................................................................ 138 |
| 15.2. **The Cutoff Slice Option** ....................................................................... 142 |
| 15.3. **The Attributes Slice Option** ................................................................... 143 |

| 16 | **Reporting Information** ........................................................................ 145 |
| 16.1. **Main Menu Publish Selections** .......................................................... 145 |

| 17 | **Sensitivity Analysis** ................................................................................ 151 |
| 17.1. **Overview of Steps Involved in Performing a Fault Tree or Event Tree Sensitivity Analysis** ................................................................................................. 151 |
| 17.2. **Permanent Modifications of Logic Models or Basic Event Data** ................................. 151 |
| 17.3. **Change Sets: Making "Temporary" Data Changes** ........................................ 152 |

| 18 | **Transferring PRA Model Data** .................................................................. 157 |
| 18.1. **Archive Project Utility** ........................................................................ 158 |
| 18.2. **Integrate Project Utility** ....................................................................... 159 |
| 18.3. **The MAR-D Module** ........................................................................... 161 |
Section 1 contains an introduction to the SAPHIRE 8 Basics course material, an overview of probabilistic risk assessment (PRA), and important definitions and concepts.
1.1. Overview of SAPHIRE Basics Course Material

The SAPHIRE Basics course material is intended to both (1) provide guidance for learning SAPHIRE during the Basics class and (2) become a stand-alone reference document after finishing the class. Thus, the format for the class material is a combination of the traditional “overhead-type” of presentation information with a structured, reference-type document.

SAPHIRE screen displays will be shown as they appear on your video display as shown below (without the quick navigation welcome screen).

The left side of the screen displays a resizable, customizable series of lists containing important PRA elements found in the current project. This series of lists is referred to as the List Panel and can be added to or subtracted from by using View on the main menu.

When discussing a particular sequence of menu options, the nomenclature

**MAIN Menu → Submenu Option**

will be used to indicate the main SAPHIRE menu option and any successive submenu options.
1.2. **SAPHIRE - What Is It and What Can It Do?**

- SAPHIRE is an integrated PRA software tool that gives a user the ability to create and analyze fault trees and event trees using a personal computer.

- Integrated Reliability and Risk Analysis System (IRRAS) was originally released in 1987 (version 1.0). Other versions of IRRAS include 2.0, 2.5, and 4.0. Additions and improvements have been added to each version.

- Creation of 32-bit IRRAS, version 5.0, in 1992 resulted in an order of magnitude decrease in analysis time. New features included: individual codes modules combined into a single module; end state analysis; fire, flood, and seismic modules; rule-based cut set processing; and rule-based fault tree to event tree linking.

- SAPHIRE for Windows, version 6.0, is released in 1997. Use of a Windows user interface makes SAPHIRE easier to learn and use.

- SAPHIRE for Windows, version 7.0, is released in 1999. This is latest production version of the SAPHIRE code.

- SAPHIRE for Windows, version 8.0, is released in 2010. The user interface has been completely rewritten. This manual is written for version 8.x of the software.

- SAPHIRE contains several features:
  - PC-based fault tree and event tree graphical editors
  - Cut set generation and quantification
  - Importance measures and uncertainty modules
  - Relational database with cross-referencing features
  - External events analysis (e.g., seismic)
  - Rule-based recovery and end-state analysis
  - Common Cause Failure (CCF) basic event capabilities

- SAPHIRE minimal hardware requirements:
  - Windows 2000 or greater
  - Pentium class IBM-PC compatible with 2-button mouse
  - 50 MB free disk space (minimum for installation)
1.3. The Class Workbook

♦ The workshop problems for the SAPHIRE class are contained in a separate handout, referred to as the “workbook” or "workshop manual."

♦ The workbook allows the SAPHIRE Basics class to be tailored to specific audiences. This “tailored-problem” format gives the freedom to present specific topics or problems centered around the expected needs of the students.

♦ The workbook follows the same format as the course material, and together provides an integrated reference package for the SAPHIRE code.

1.4. Overview of PRA

Probabilistic risk assessment (PRA) is a method to:

Identify, characterize, quantify probabilistically, and evaluate hazards

♦ The process of measuring risk (i.e., PRA) asks:

What can go wrong? (accident scenarios)
How likely is it? (probability)
What are the consequences? (adverse effects)

♦ Hazards could include

Hydrazine Leak (e.g., loss of space craft)
Electrical hazard (e.g., electrical shock)
Thermal hazard (e.g., thermal blast effects from an explosion)
Chemical hazard (e.g., a release of toxic chemicals)
1.5. Definitions

**Risk**

The potential of loss or damage resulting from exposure to a hazard.

**Safety**

Represents an acceptable level of risk relative to the benefits derived from the hazards-causing activity.

**Probability**

The two common interpretations of probability are:

**Frequentist** (the relative frequency or empirical approach)

The probability of event A is given by:

\[ P(A) = \lim_{n \to \infty} \left( \frac{X}{n} \right) \]

where X is the number of times event A occurred out of n number of repeated trials. For a fixed n, the value of P(A) is the relative frequency of occurrence of event A. Consequently, increasing n will improve the estimate of P(A).

**Subjective** (the “degree of belief” approach)

The probability P(A) is the measure of uncertainty or degree of belief one has of event A. For example, the knowledge of symmetry for a particular coin may lead an analyst to postulate that the probability of tossing a head on a toss is 0.5. The subjective method requires that probability be assigned in a consistent manner.

**Reliability**

The probability that a system will perform satisfactorily (i.e., does not fail) for a designated period of time (or number of cycles) and under specified operating conditions. The **Unreliability** is the complement of the reliability, that is, the probability that the system *does fail* within a designated period of time and under specified operating conditions.
Availability
The instantaneous availability is the probability that a system will perform satisfactorily at a designated point in time when used under specified operating conditions. The evaluation of system availability includes operating time, time to test, active repair time, administrative time, and logistics time. The Unavailability is the complement of the availability.

Accident Sequence
The combination of an initiating event with system failures and successes (defined by an event tree) which results in a definable outcome.

Dominant Contributors
Failures which are quantitatively the largest contributors (i.e., “dominant”) to the likelihood of the defined event (e.g., accident sequence, system failure).

Minimal Cut Set
A minimum combination of failures needed to result in the occurrence of the event of interest (e.g., accident sequence, system failure).

Consequence
A measure of the degree of damage or loss experienced given a particular accident sequence.

Fault Tree Linking
A technique whereby the fault tree logic is combined with the event tree logic (i.e., successes and failures) resulting in a logic expression for each sequence in the event tree.
1.6. Major Steps "NUREG-1150 Type" PRA Process

- The output of the Level 1 PRA is the core damage frequency and includes:
  - Identification of accident sequences and their frequencies.
  - Identification of dominant contributors to core damage.
  - Classification of accident sequences into Plant Damage States.

- Event tree and fault tree analysis are most commonly used in Level 1 PRA.
1.6.1. Event Trees

- Event trees are logical representations of significant responses to initiating events.
  - Each sequence results in either a safe condition or an accident condition.
  - Event trees relate systems/functions to a sequence progression.
  - Event trees provide an end-to-end traceability of accident sequences.

- Event trees provide a traceable way to perform the following functions:
  - Identify accident sequences.
  - Identify essential safety system functions.
  - Quantify sequence frequencies.
1.6.2. Fault Trees

♦ Fault trees are logical representations of the credible failures that can cause an undesired event to occur.

◊ The undesired event is stated at the top of the fault tree.

◊ The fault tree gates specify the logical combinations of basic events that lead to the top event.

◊ Fault trees can be used to identify system “weaknesses.”

◊ Fault trees can help to recognize interrelationships between fault events.

◊ SAPHIRE evaluates the fault tree to find system minimal cut sets and the system failure probability.

♦ Fault trees consist of logic gates and basic events as inputs into the logic gates.
Logic Gates

Represent the Boolean operation (e.g., union, intersection) of the input events.

Basic Events

Represent a fault such as a hardware failure, human error, or an adverse condition.

1.7. Accident Sequence Quantification Steps

1. Link fault models to the event tree sequences.
2. Evaluate each accident sequence for minimal cut sets.
3. Quantify the accident sequence minimal cut sets with event data.
4. Add operator recovery actions (if not already in the fault tree and event tree logic models).
5. Determine the dominant accident sequences.
6. Partition the accident sequences into appropriate plant damage state bins.
7. Perform sensitivity, importance, and uncertainty analysis on the accident sequences.

1.8. Installation of SAPHIRE

♦ Perform the following steps to install SAPHIRE:

◊ Download the current version of Saphire8XXXX.exe from the SAPHIRE website to your pc. (Alternatively, use an installation CD and place it into the CD drive.)
◊ Follow the installation program instructions.

♦ The installation program will make a subdirectory on your hard drive to store SAPHIRE. (Must have read/write access on directory the software and projects [databases] are located.)

Databases (such as the DEMO database) can be contained in any subdirectory that is chosen (e.g., C:\DEMO or C:\Saphire8\DEMO).

The database subdirectory will contain the relational database files.

*.IDX files contain data indices
*.BLK files contain variable length data (e.g., cut sets)
*.DAT files contain actual data and data pointers.
1.9. SAPHIRE User Settings

The SAPHIRE User Settings dialog is used to customize the SAPHIRE code. Individual projects can be customized specific to the types of analysis to be performed.

- The user settings are available by selecting Project → User Settings.
- The following option settings are available:
  - “General Settings” default values
  - “Analysis options” default values
  - “External Solvers” default values
  - “Rules Editor” default values
  - “Graphical Editor” default display options
  - “Significance Determination Process (SDP)” default values
  - “RASP CCF” default settings
1.9.1. General Display User Settings

General Settings can be modified as follows:

♦ Use the mouse or TAB key to move to a particular field.
♦ Change the setting(s), select the next User Settings Category, and repeat.

Click OK to save all your choices for the project that is currently selected. Each project starts with the defaults and may be modified with a different set of constants.

“General Settings” screen
1.9.2. Analysis Options Settings

The “Cut Set Truncation” options are used when generating cut sets for both fault trees and event tree accident sequences. The options selected in each combo box will be used when generating either fault tree or event tree cut sets.

The “Uncertainty Sampling Method” option sets the default uncertainty analysis type by selecting either Latin Hypercube or Monte Carlo from the combo box. Also, the default random seed and number of samples can be specified.

“The Mission time” field specifies the default mission time. This default is used only for those basic events that have a calculation type using the mission time and that event’s mission time field is set to zero.
The “Quantification Method” option specifies which analysis method to use when quantifying the cut sets.

1.9.3. External Solvers Settings

The External Solver option allows the analyst to use different solving engines to generate cut sets and then quantify those cut sets.
1.9.4. Rules Editor Constants Settings

The Rules Editor option sets the default font for the rules editor.
1.9.5. Graphical Editor Constants Settings

The fault tree and event tree graphical constants set default node style, size, and some control options. Node color and fill effects have meaning in the model and are not customizable in this form.
1.9.6. SDP Settings

The SDP options are to set up the cut set generation option and allow other quantification processes. The first check box is to change the default cut set generation and quantification from a “multi-pass” option to a "single-pass". The second option allows the analyst to change the truncation option from the default and the last option will multiply in Large Early Release Frequency (LERF) factors after the SDP has been evaluated.
1.9.7. RASP CCF Settings

The RASP CCF settings are to change the common cause failure (CCF) basic events from using one calculation method to the new R-calculation type. Also, allow for adjustment to the CCF basic event probability given a change in basic event’s probability utilized by a flag set.
Section 2 presents an overview of the SAPHIRE database structure. Included in this section are discussions of SAPHIRE projects, nominal case versus current case, nominal case updates, and change sets.
2.1. SAPHIRE Projects

In SAPHIRE, the term “project” represents a single, specific database.

**Project (Definition)** -
A group of fault tree logic and graphics; event trees and sequences; basic events and related data; cut sets; analysis results; and descriptions.

2.1.1. Opening a Project

(When SAPHIRE is executed, it loads up the last project that was being utilized.)

To select an existing project:

If there is not a current project available or you are opening a second session of SAPHIRE on your computer, it will start with an option screen to open an existing project or create a new one.
Existing projects can be found through the browsing function or by clicking the Open Existing Project icon.

Clicking on Browse or Open Existing Project will open up a window to select the project. The user can also use the File → Open existing project option on the main menu bar at the top left of the screen.

An “Open Project” window will appear. Use the various Window Explorer options to find the folder containing the existing project.

To open the latest version of the project, select and open the *.SRA or FAM.DAT file; or, to open an archived version of the project, select a *.zip file.

To create a new project:

♦ Use the main menu File → New → Project option or (select the New icon on the startup screen).

♦ A “New Project” window will appear. Type the new project name and (optional) description.
♦ Verify that the Parent Directory is acceptable. If a different parent directory is desired, type in the new parent directory.

♦ Verify that the Folder Name is acceptable. By default, the Folder Name matches the project Name. (If the Folder Name appears blank, move the cursor out of the project Name field so that the Folder Name can update.)

♦ Click OK. The main SAPHIRE menu will be displayed and the project name and the project location will be shown in the title bar above the menu.

♦ Modifications to a database (e.g., a new fault tree is developed) are always made to the currently selected project.

♦ For a given project, only one list is kept for all types of information. Thus, within a project, only a single copy of a particular fault tree, event tree, or basic event is ever stored in the database.
2.2. Nominal Case versus Current Case Data

♦ Nominal case and current case are two separate parts of a project database.

◊ Nominal case data is stored in the data base files as a “permanent” record.
◊ Current Case data is used to perform an analysis (e.g., cut set generation and quantification).

The Current Case is:
◊ Created (via the Generate option [done automatically]) by applying change sets to base case data and solving the fault trees, etc.
◊ Used for sensitivity or event analysis

♦ All SAPHIRE calculations use the data stored in the current case.
♦ Current case can equal the nominal case in order to reproduce the original study stored in the nominal case.
2.3. Generating Event Data

The **Generate** process transfers nominal case data to the current case (after making changes specified in any marked change sets). SAPHIRE **always** uses current case data for analysis. This step is done automatically prior to solving for cut sets (fault tree, accident sequences, etc.)

---

**Change Sets (Definition)**

**Change Sets** are a user-defined set of changes (think data filter) that will be applied (on the nominal case data) when data is transferred to the current case via the **Generate** process. Multiple change sets can be defined and applied singly or in combination.
2.4. Rules for Creating and Using Change Sets

- No limit to the number of change sets that can be added to the data base.
- Change set name is limited to 24 characters and the description is limited to 120 characters.
- A change set can contain one class change and unlimited individual probability changes.
- Multiple change sets can be used in combination to create different sensitivity studies.
EXAMPLE: Two change sets are developed. The first is named “A” and sets all valves to failed. The second is named “B” and sets all pumps to failed. The possible scenarios are

<table>
<thead>
<tr>
<th>Change set(s) that are marked</th>
<th>Sensitivity case</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Original nominal case data</td>
</tr>
<tr>
<td>A</td>
<td>Valves failed</td>
</tr>
<tr>
<td>B</td>
<td>Pumps failed</td>
</tr>
<tr>
<td>A and B</td>
<td>Both valves and pumps failed</td>
</tr>
</tbody>
</table>

The order of “marking” a change set is important. (Change sets are marked by double-clicking the line containing the change set.)

◊ The first selected change set will be the first one that is applied.
◊ Later changes will overwrite earlier ones if there is any overlap.
◊ A particular change set may include both a Class change and Single changes. The Class change is applied first and then the Single changes are applied second. Thus, the individual probability changes will overwrite a class change if both types are in a particular change set.

Class Changes

Class changes use a basic event attribute to search for a class of basic events to which the defined change applies

- The search criteria are defined first
- The change to be applied is then defined

Single Changes

Single changes only modify individual, user-identified basic events

- The desired basic event is selected
- The changes to the basic event are then defined
2.5. **Nominal Case Update**

- Nominal case data and results are changed by **updating** the nominal case. Updating the nominal case transfers the current case data or results into the Nominal case.

- **Nominal Case** results are stored in the data base files as a "permanent" record.

- **Nominal Case** results are stored when the cut sets are generated via checking the “Copy Cut Sets to Nominal Case” box.
Section 3 shows how to use the Main Menu Toolbar. The Main Menu Toolbar section covers all of the main toolbar utilities which include the File, View, Bookmarks, Publish, Project, Tools, and Help tabs.

### 3.1. File

The main toolbar File menu consists of file manipulation options, an option to create a new project or a new event tree, fault tree, or basic event in the current project, and a macro manager.

#### 3.1.1. File → Open Existing Project

*Open existing project* will open a Windows browser where the operator can select an existing project.

#### 3.1.2. File → Archive, Integrate Project, and Load/Extract

*Archive, Integrate Project, and Load/Extract* functionalities are covered in the Transferring PRA Model Data section.
3.1.3. File → Save As

Save As will save a copy of the current project under a different name.

3.1.4. File → Macros

Macros will open the macro manager. These are not the macros discussed in the various rules sections of this manual. Macros created here can run SAPHIRE 8 routines in an automated fashion. Macros can be imported, exported, and run from this macro manager. Periodic functions and reports can be automated using a macro routine. The macros are written in a language very similar to the xml language.

3.1.5. File → New

New includes an option for creating a new project and provides another way to create a new event tree, fault tree, or basic event in the current project.

3.2. View

The main toolbar View menu controls the display of the list panel on the left side of SAPHIRE 8. The list panel opens as a default showing the panes for Basic Events, Fault Trees, Event Trees, Workspaces, and Open Windows.
3.2.1. View → Open Windows

*Open Windows* will open a submenu for the display of a *Hover Window* in addition to the *Side List*. Any combination of open or closed lists can be displayed. As with all of the View options, activate the selection by clicking on the option and a check mark appears next to the active options.

3.2.2. View → Basic Events, Fault Trees, Event Trees, End States and Workspaces

Use of the lists for *Basic Events, Fault Trees, Event Trees, End States, Change Sets* and *Workspaces* are covered in their respective topic sections throughout the manual.

3.2.3. View → Event Tree Groups

*Event Tree Groups* are sub-groups of event trees for convenience of the user. The groupings are mutually exclusive (one event tree cannot be in two groups).

To illustrate this, open the DEMO-EE project and select the Event Tree Groups from the view menu. This project has already been set up to group the FIRE, FLOOD, and SEISMIC event trees. The PROJECT event trees are event trees that are not grouped. The purpose of grouping event trees is to allow for quick analysis of sequences only pertaining to certain groups. This example is set up for phenomenological delineation; however, groupings in other models could just as easily be set up for any other analysis such as internal/external events.

To view an event tree grouping, click the icon to expand the list of event trees below the group name or alternately double click on the group name to open the editor.
To create a new group, in the Edit Event Tree Groups editor select [button name], name the group and then move the desired event trees to the Grouped Event Trees pane on the right side of the form using the arrow buttons to transfer event trees from Non Grouped to Grouped and vice versa. Select [button name] to save the new group.

3.3. Bookmarks

The main toolbar **Bookmarks** menu is one way to create bookmarks. Bookmarks are sub-lists of objects that are user definable. For example, create a bookmark of all basic events starting with the text “C-” by highlighting the events in the Basic Events pane. Then right click on the highlighted selection and choose “Set Bookmark”. This set of highlighted events may then be named and given a description.
Main Menu  →  Bookmarks is the path to manage bookmarks. To select the newly created CCS Events bookmark, just select the path in the Bookmarks sub-menu:

![Bookmarks screenshot]

When the specific Bookmark is selected (from the Bookmarks option) only those events in the bookmark will be highlighted in the appropriate list pane.

![Basic Events screenshot]

From the Edit Bookmarks dialog, the Bookmarks may be renamed (via Edit), deleted (via Delete) or a new bookmark may be created in the Edit Bookmarks by choosing New and then by dragging and dropping items into the Bookmark Items pane.

Masked Bookmarks

There is also a Masked Bookmark function that makes it easy to choose similar items. Use the bookmark editor to create the same bookmark as above. Create a new bookmark and name it. Then click the Masked Bookmark checkbox. Wildcard searches can be made by use of the “*” symbol, as shown. Click on ![Apply Mask] to add the mask selected items.
Deleting a Bookmark DOES NOT delete the basic events (or other objects) in the Bookmark list. The objects in the Bookmark list are left untouched outside of the bookmark framework.

3.4. Publish

The main toolbar Publish menu includes reports for the entire project and each of major components of the PRA: basic events, fault trees, event trees and end states. A detailed review of their options can be found in a later section.

- The Project Report lists statistics of the numbers of event trees, fault trees, basic events, and gates.
- Basic Event Reports include listings; either all selected or sorted by type such as RASP CCF and HRA Events, uncertainty, and categories. The custom report option includes even more choices.
Fault Tree Reports, Event Tree Reports, and End State Reports all can display lists, cut sets (broken down in several ways), linkage rules, post-processing rules, importance measures (overall or by component or operator action) and graphics. The custom report option includes even more choices.

The Publish menu option will be discussed in greater detail in later sections.

3.5. Project

The main toolbar Project menu provides a single location to make modifications to the current project, e.g., Modify, Flag Sets, and User Settings.

3.5.1. Modify (Project Settings)

The Modify option allows the analyst to add information about the project that will be stored and can be produced through the different reports.
The Edit Project option has five tabs that store information about the current project.

- **Storage Info** - identifies the location where cut set information and the relational files will be stored (this will always be the default folder the project is located and not editable in the Edit Project form).

- **General Info** - allows the analyst to fill add information about the current project, i.e., version, frequency units, site hazard curve (for seismic analysis) and other important information. The “Read Only?” check box will lock the files so others will only be able to review the logic and generate cut sets and will not be allowed to make any logic changes.

- **Additional** - provides an area to document information about the project, i.e., general philosophy, restricted use, and plant specific usage limitations. These fields allow for general information about the project.

- **SPAR** - this tab will tell SAPHIRE if the current project is a Standardized Plant Analysis Risk model. The check box will open up some of the report options and other options that are related directly to the SPAR models.

- **Notes** - this tab provides additional space to include any notes/documentation about the project.

### 3.5.2. Edit Rules

The Edit Rules option allows the analyst to add project level rules to be applied to all fault trees and all event trees.

- **End State Partition** - this rule is used to create partitioned cut sets based on defined search criteria.
- FT (Post-processing) - this rule is used to apply post-processing options to the resultant cut sets generated from the fault tree logic. This rule will be applied to all of the highlighted fault trees that are solved.

- ET (Post-processing) - this rule is used to apply post-processing options to the resultant cut sets generated from the event tree logic (accident sequences). This rule will be applied to all of the highlighted event trees (accident sequences) that are solved.

### 3.5.3. Documentation

The Documentation option allows the analyst to add links to different documents that contain information about the project. This will be stored in SAPHIRE.

![Documentation Window](image)

### 3.5.4. Categories

The Categories option (is for SPAR model development) allows the analyst to create system, component, failure mode, and component specific information that can be linked to the developed basic event.
3.5.5. Phases

The Phases option allows the analyst to create multiple phases that the project can transition between. For example, a thruster must operate for $x$ hours during the early part of a mission, shut down and then operate for $y$ hours during a later part of the mission. This option allows for the same component to contain different probabilities based on where in the mission it is demanded.
3.5.6. Model Types

The Model Types option allows the analyst to create different model types that the project (systems and/or components are susceptible to). For example, a component can be susceptible to random type failures and also earthquakes. A different probability can be assigned to the same component depending upon which model type is being assessed.

3.5.7. Flag Sets

The Flag Sets option allows the analyst to create flag sets that are applied to fault trees or event tree accident sequences. Flag sets are designed to modify the logic when cut sets are being generated.
3.5.8. Change Sets

The Change Sets option allows the analyst to create change sets that are applied to fault trees or event tree accident sequences when generating cut sets. (This is another location where change sets can be created and/or modified.)

3.5.9. Histograms

The Histogram option allows the analyst to create histograms that can be used as uncertainty distributions for components that may not have a continuous distribution. This is where the site histogram is created to be used for the project when performing seismic analysis.
3.5.10. User Settings

The User Settings option allows the analyst to provide the default settings that the project will use for cut set generation and quantification; output options; etc.

3.6. Tools

The main toolbar Tools menu provides search, cross-reference, and project recovery and status functions.

3.6.1. Search

Search can be accessed both from the main toolbar Tools ➔ Search and also from the Search window which is above the User Area in all views.

The search function works just like a standard internet search engine. There is no need to place a wildcard symbol in the search text. Enter in a string of characters and search on that string. For instance, “cc” is entered in the simple search below. The search is by default not case sensitive.

Highlighting or placing the mouse over an item in the results panes provides a preview of the item:
3.6.2. Cross References

The Cross Reference tool finds what is used by the item or what uses the item and displays it in a hierarchical tree. For instance, to find out what the Basic Event C-CKV-CC-A is used by, highlight the basic event in the list panel, then choose Tools → Cross References. Note in the illustration below, that the further expansion is available by clicking on the “+” next to the items of interest. To view all of a root type, such as Basic Events, use the Root Type pull down menu. The view can also be changed from Used By to Uses.
3.6.3. Check Project

Check Project checks the project’s items for common errors and omissions. Tools → Check Project opens the Project Check form:

Choose which items to check by clicking on the desired check boxes. To check all items for all errors, click on Check All. The sub-check boxes perform the automated functions and are not activated by the Check All option. These sub-check boxes must be activated by clicking on them.

![Project Check Form](image)

3.6.4. Recover Project

The Recover Project utility allows the user to re-write the project database relational files. The files will be compacted and checked for consistency.

Some indications that a database recover is necessary include:
◊ Data elements such as events/fault trees have been deleted and seem to reappear
◊ During cut set generation or update, the results seem surprisingly high
◊ Cross Reference reports show/don't show events being used properly
◊ Events/fault trees that don't appear to be referenced cannot be deleted, and
◊ After a software version update, SAPHIRE displays a message stating a database recovery is required.

You may recover the database anytime because the rebuild process compacts the data and generally helps the software run faster. This option will recover all key indexes and then recover the cross-references. This process may take several minutes to complete. If your database has not been damaged, this option will just restructure and optimize your database.

3.6.5. Load Accident Matrix

The load accident matrix was developed as an option to load external event information and automatically create event tree sequences and flag settings for specific evaluations (e.g., fire zones, flood zones).

3.6.6. Convolution Ev Mapping

The convolution event mapping option was developed to automatically calculate convolution probabilities for offsite power recovery. SPAR models contain these power recovery basic events that have been calculated offline.

3.6.7. View Error Log

The Error Log displays errors encountered in solving portions of the model or loading data, etc.
3.7. Help

The Help menu provides a path to the .html topic help files and information on the software.

♦ **Topic Search** - opens the .html based help file for the main page where hyperlinks can be followed to find help on SAPHIRE 8 topics.


♦ **Help Videos** - opens the SAPHIRE home page and allows the analyst to select different topics. These videos provide step by step instructions to perform select tasks.

♦ **SAPHIRE 8 NUREG/CR-7039** - directs internet browser to the NRC library and allows the analyst to open/save one of the seven SAPHIRE volumes.

♦ **About SAPHIRE…** - opens an informational graphic about the SAPHIRE 8 software.
♦ Fixes Document - lists the changes that have been incorporated into the latest version of SAPHIRE.

♦ Credits… - thanks those whose efforts have helped the development of SAPHIRE over the years.

♦ Disclaimer - discusses the restrictions on the code and other legal information.
Section 4 covers navigation of the model creation and editing functions and the use of the lists panel.

4.1. SAPHIRE Model Development Area

Creating and modifying the base reliability model for a project database is performed in windows opened up in the model development area, which is where the gem graphic is located. The windows can be expanded beyond the graphical area and dragged anywhere on the computer screen. The various Fault Tree, Event Tree, and Basic Event screens opened up in the Model Development area will open with their own main menu and title bar, such as the event tree one here:

4.1.1. SAPHIRE Window Management

The various windows opened in the Model development area can be managed through sizing and storing for ease of use and quick retrieval.

4.1.1.1. Sizing a Window

Most SAPHIRE 8 dialogs and windows can be resized by dragging its edges until it is the size you want. You may also maximize and minimize the windows as needed.

A SAPHIRE specific button is available next to the minimize and the maximize buttons on the title bar. Click to automatically resize and reposition the window so that the window fits exactly within the model development area.

4.1.1.2. Open Windows

In SAPHIRE 8, you can have multiple windows open at the same time. This includes multiple windows of the same type. For example, you can
have two different fault tree editor windows open at the same time, as well as several basic event editors.

Every window that is open appears in the “Open Windows” list on the Lists Panel and is grouped according to the type of window it is. Click on an item in the “Open Windows” list to bring that window to the front of the others. This will restore a window if it has been minimized.

### 4.2. Lists Panel

The main screen of an opened project contains a resizable panel of lists along the left side of the window. This panel is connected to the left side of the main window, but you can grab the right border of the panel and stretch or shrink the width of the panel as needed.

Press the ‼️ button to collapse a list, and ⌉ to expand it.

You can choose which kinds of lists appear in the panel by toggling the check marks next to the different list types in the View option available on the main menu. For example, to display the End States list in the List Panel, choose View → End States, and make sure a check box appears next to the End States menu option. To remove the End States list from the List panel, choose View → End States and make sure a check box does NOT appear next to the Basic Event menu option.

#### 4.2.1. List Filters

The “Basic Events”, “Fault Trees”, and “Event Trees” lists contain a drop down list of filters next to their list labels. For fault tree and event tree lists, you may choose the “All”, “Main Trees”, or “Sub Trees” filters to display only the trees in the list that meet the filter criteria. For basic events, several filters are available, such as Initiators, Templates, Compound, and House. The “Standard” filter displays all available events that would normally be used in fault tree modeling, and excludes “helper” events such as template; system generated, developed, and value events.
4.2.2. Selecting from a List

One or more items can be selected from each list for processing. An item in a list is selected if it is highlighted. There are various ways to select items from a list:

♦ To select a single item, click with the left mouse button on the desired item and let go of the mouse button.

♦ To select multiple continuous list items, you can click with the left mouse button the on first desired item, then while holding down the Shift key, click the last desired item.

♦ To select multiple non-continuous items in the list, click several items while holding down the Control key.

♦ To select all items in the list, hold down the Control key and press “A”.
Section 5 introduces event tree terminology and SAPHIRE event tree modeling conventions. This section also covers how to enter an event tree into SAPHIRE using the graphical event tree editor and also how to edit an existing event tree. It also shows how to customize the visual display of the event trees.
5.1. Event Tree Development

Event trees are developed by starting with an initiating event and branching to the right as various safety functions are questioned for success (up branch) or failure (down branch).

Event trees provide a traceable way to perform the following functions:

◊ Identify accident sequences
◊ Identify essential safety system functions
◊ Quantify sequence frequencies

Event Tree Definition:
Event trees are logical representations of significant plant responses to initiating events with each sequence resulting in either a safe condition (such as safe shutdown) or an accident condition (such as core damage).

Event Tree Development Process
5.2. Event Tree Terminology

Some key terms used in Event Tree development are:

**Initiating Event** – An initiating event is an operational occurrence (such as a LOCA or transient) which threatens fuel safety and may require safety system response to avoid core damage.

**Top Event** – Safety systems (or human actions) intended to respond to the initiating event.

**Branching** – A branch underneath a top event indicates success with an up branch and failure with a down branch.

**Pass** – When there is no branching beneath a top event, then the top event is not relevant to the particular sequence.

**Sequence** – This is the branching path, from initiating event to end state, which is a unique combination of system failures and/or successes.

**End State** – This is a group of accident sequences which share certain characteristics, or outcomes, that the analyst delineates. These may be related to ability to perform a safety function or timing of functional failures.

5.3. SAPHIRE Event Tree Conventions

Conventions used in SAPHIRE Event Tree development include:

**Event Tree Names** – Event tree names may be up to 24 characters. The event tree name does not have to be the same as the initiating event name.

**Top Event Names** – 24 characters allowed.

**Initiating Event** – Only one initiating event allowed per event tree.

**OK, Success** – If the end state column entry is OK or Success, then logic for that sequence will not be developed, and the sequence will not be analyzed.

**Branch** – SAPHIRE always uses success for the up branch and failure for the down branch.

**Transfer Trees** – An event tree can branch to another event tree by using transfers. You must indicate that a transfer is to be invoked and specify the
transfer event tree file name. The first top event in the transfer tree is ignored by the calling tree.

Forbidden Characters – The symbols *, ?, \, @, /, and spaces are not allowed in naming SAPHIRE event trees or top events.

5.4. Beginning an Event Tree Editing Session

5.4.1. Adding a New Event Tree:

Double click “New Event Tree” from the Event Trees list on the List Panel, or choose File → New → Event Tree.

An event tree editor window will open:

![New Event Tree Properties](image)

Enter the information on the form and click OK, the “empty tree” will display:

![SAPHIRE Event Tree Editor](image)
5.4.2. Opening an Existing Event Tree:
Double click on the desired event tree in the Event Tree List Panel, or highlight the event tree; right click and choose Edit Logic from the pop-up menu.

5.5. Inserting Top Events

Insert top event to the left toolbar button

To add a top event to the left of an existing top event, choose the Insert Top to the left button. Move the null cursor over to the top event box, and the cursor will change to . A left click will insert a new box with the description “New Top Event” and an arbitrary name to the left of the initiating event box. Note that you cannot insert a top event to the left of the initiating event.

To add additional top events, continue to click on the initiator box or any top event to add additional top events to the left of the clicked box.

Insert top event to the right toolbar button

To add a top event to the right of another top event, choose the Insert Top to the right button. Move the null cursor over to the top event box, and the cursor will change to . A left click will insert a new box with the description “New Top Event” and an arbitrary name to the right of the initiating event box.

Select toolbar button

When you are finished adding top events, click on the hand toolbar button to leave Insert mode and enter Select mode. Alternately, you can right click to exit the insertion cursor.
5.6. Modifying top events

Editing a top event:

To edit the name and/or description of a top event or initiating event, highlight the Top Event, right click and choose the Edit option. Or, if you are in Select mode (not Insert mode) you can double click a top event. The Edit Top Event window will be displayed.

![Edit Top Event Window]

**Top Event Name** – The name of the top or initiating event (maximum of 24 alphanumeric characters).

**Top Event Description** – Brief description of the top (maximum of 120 alphanumeric upper and lowercase characters).

**Decomposition ET** - Tells SAPHIRE if this top will be a fault tree logic model or a transfer type event tree.

Fill in the name and description for the selected Top Event. To assign a top event that already exists in the project, click the drop down box, select the existing top from the combo box (listing all existing fault trees). The corresponding description will automatically be filled in. Press OK to close the Edit window and view the updated event tree drawing.

Deleting a top event:

To delete a top event, select the top event by left clicking the mouse, right click the mouse and select the Delete option from the pop-up menu. (The Delete option will be grayed out if there are branches associated with the selected top. You must remove the branches before you can delete the top. See Deleting Branches.)
5.7. Editing Event Tree Branches

Adding up and down branches, adding descriptive text on branch lines and deleting are covered in this sub-section.

5.7.1. Adding event tree branches

To add branches to an event tree, choose the Insert Up Branch or Insert Down Branch toolbar button.

- Insert Up Branch toolbar button
- Insert Down Branch toolbar button

Select the branch point \( \) and the null cursor \( \) will change to the appropriate branch cursor (up) \( \) or branch cursor (down) \( \), depending upon the toolbar button chosen. A left mouse click will add a new branch in the event tree above or below the selected branch.

**TIP:** When a valid branch point is selected, the cursor will change. Position the cursor so that the tip of the arrow is inside the branch point circle.

5.7.2. Deleting branches

To delete an unwanted branch, right click on the unwanted branch point \( \) and choose **Delete** from the pop-up menu.

5.7.3. Adding text to a branch

To attach text to a branch, double click on the branch point \( \), or right click, and choose **Edit** from the pop-up menu.

Enter the branch text in the Branch Annotation field and press OK. The text will display above the branch point. The text will stay with the branch as the tree is resized and/or edited.
5.7.4. Expanding and Collapsing branches

To aid the development of larger trees, portions of your event tree can be hidden (collapsed). The nodes will still exist, but will not be visible in the editor until they are expanded. This allows you to focus on a particular section of a tree. To collapse a node, while in Select mode (click \( \text{Select mode} \) to get into Select mode if needed), click the \( \text{Collapse} \) symbol that immediately follows the node you want to collapse. All branching that originates to the right of the node (including sequence/end state information) will disappear, and in its place will appear \( \text{Collapse} \).

5.8. Editing Sequence/End State Information

Each sequence path has additional columns that contain information about the sequence. This information includes the name of the sequence, the end state of this sequence, its frequency, and a comments field. If the sequence continues to another event tree then the name listed in the end state field is the name of the transfer event tree. This additional information can be edited and displayed.

5.8.1. Edit End-State Description

To enter additional information about a sequence end state, select the sequence end state of interest by left clicking the mouse, then right click on the sequence box and choose the Edit option. The Edit End-State Description dialog will be displayed.

End-State Name – The name of the sequence end state. This is limited to 24 alphanumeric characters. If the sequence transfers to a sub-event tree, check the Transfer box. The name listed is used as the transfer event tree.

Sequence Name – This is the informational name of the sequence. SAPHIRE will not refer to the sequences elsewhere in the project using this name – it only appears in the logic editor as descriptive information, and is therefore generally not used.
**Frequency** – Contains the frequency information that was previously input for the sequence. SAPHIRE 8 does not automatically update this field as the value becomes available.

**Comments** – Free-form comments up to the maximum limit of 24 alphanumeric characters.

### 5.8.2. View Sequence/End State Information

To view or hide each column of information: From the editor’s main menu, toggle the check marks for the following options:

- **View → End State Names**
- **View → Frequencies**
- **View → Comments**
- **View → Sequence Names**

### 5.9. Editing the Visual Display of Event Trees

#### 5.9.1. Adjust the visual display of the event tree

The size of the top event boxes can be selected to be small, medium, or large by check marking the desired size in the editor’s main menu, **View → Box Size**.
5.9.2. Zooming

To enlarge or shrink the view of the event tree, use the zoom toolbar options, or choose the equivalent option from the main menu.

<table>
<thead>
<tr>
<th>Toolbar option</th>
<th>Menu equivalent</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View → Zoom In</td>
<td>View → Zoom In</td>
<td>Enlarge the scale of the drawing by a step.</td>
</tr>
<tr>
<td>View → Zoom Out</td>
<td>View → Zoom Out</td>
<td>Reduce the scale of the drawing by a step.</td>
</tr>
<tr>
<td>(none)</td>
<td>(none)</td>
<td>Enlarge or reduce the scale of the drawing to the step value selected combo box, where 100% is considered normal.</td>
</tr>
<tr>
<td>View → Fit In View</td>
<td>View → Fit In View</td>
<td>Size the drawing so that the entire drawing is visible in the window.</td>
</tr>
</tbody>
</table>

Use the scroll bars to change the portion of the diagram displayed in the window.

5.10. Ending the event tree editing session

To save the event tree, from the Event Tree Editor menu bar choose File → Save.

To save a duplicate of the tree, use File → Save As and enter the name and (optional) description of the event tree as directed. Designate the event tree as a main or sub tree.
To exit without saving, from the Event Tree Editor menu bar choose File ➔ Exit. Choose No to quit without saving.

TIP: To rename an event tree or change the description or main/sub tree designation without exiting the editor, choose Edit ➔ Properties.

5.11. Example Event Tree
The LOSP event tree from the DEMO project:

<table>
<thead>
<tr>
<th>Loss of Offsite Power</th>
<th>Emergency Cooling System</th>
<th>Containment Cooling System</th>
<th>#</th>
<th>End State (Phase - PH1)</th>
<th>Frequency (Phase - PH1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOSP</td>
<td>ECS</td>
<td>CCS</td>
<td>1</td>
<td>OK</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2</td>
<td>SMALL-RELEASE</td>
<td>4.840E-002</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3</td>
<td>LARGE RELEASE</td>
<td>1.759E-003</td>
</tr>
</tbody>
</table>

5.12. Printing Event Tree Graphics
- To print event tree graphics, highlight event tree(s) then select Publish ➔ Event Tree Report. From the list select, “Event Tree Graphics Report”
- Select the type of output via the radio button. SAPHIRE will print the event tree(s) to the format selected (i.e., Rich Text Format [RTF]).
♦ Click the Publish button.

Or, with event tree highlighted in the event tree graphic editing mode, select **File ➔ Print**. This will send the event tree directly to the default printer.

Two options are available:

◊ Fit to single page – prints event tree on one page

◊ Grid paged format – prints event tree in different segments

Or, copy the event tree graphics and paste directly into a document (i.e., Word) by **File ➔ Export Image**. The output can be (WMF or BMP copy).
Section 6 introduces fault tree development, SAPHIRE fault tree symbols, and SAPHIRE fault tree modeling conventions. You will learn how to enter and edit fault trees by using the fault tree graphical editor.
6.1. Fault Tree Development
Fault tree development in SAPHIRE is accomplished through graphical representation.

**Fault Tree Analysis Definition:**
Fault tree analysis is a deductive failure analysis method which focuses on identifying all of the credible ways that can cause an undesired event to occur. The undesired event is stated at the top of the fault tree. The fault tree gates specify the logical combinations of basic events that lead to the top event.

**Fault Tree Development Process**

```
Plant familiarization

- From event tree top event definitions
- Define the fault tree top event
- Delineate systems and system boundaries

- Specify model assumptions and conditions
- Construct fault tree model
- Analyze model and perform check
```
6.2. SAPHIRE Fault Tree Terminology

Some key terms used in Fault Tree development are:

**Nodes** – Nodes are entries into the fault tree which consist of gates and basic events.

**Gates** – Gates are action nodes. Their output is based on the inputs received from other nodes or they transfer to another fault tree or a different part of the current fault tree.

**Basic Events** – Basic Events are probabilities of occurrence of actions or conditions. SAPHIRE 8 has many model options for basic events.

6.3. SAPHIRE Fault Tree Conventions

Conventions used in SAPHIRE Fault Tree development include:

**Fault Tree File Name** – The fault tree name must be the same as the top gate name. The fault tree name can be 24 characters long.

**Fault Tree Node Defaults** – The default node (Gates, Basic Events) Style and Size may be modified on the User Settings dialog (Project ➔ User Settings ➔ Graphical Editor).

**Fault Tree Gates** – The gate name is limited to 24 characters in length and cannot include spaces. Gates may be duplicated among different fault trees as long as the gates are identical (not recommended). Identical gates are two gates with (1) the same name and (2) the same inputs. SAPHIRE 8 defaults to a new gate name to eliminate duplicate gates.

**Basic Event Names** – The basic event name is limited to 24 characters in length and cannot include spaces.

**Top Gates** – A fault tree "page" or file can have only one top gate and the top gate must be the same name as the fault tree name.

**SAPHIRE Default Naming** – SAPHIRE will automatically assign basic event names (FTNAMEt#) and gate names (FTNAME#); however, the user will typically want to replace the default name.

**Transfer Fault Trees** – A fault tree can transfer to another fault tree by using transfer gates. The transfer gate name and the “transfer to” gate name must be
the same. The gate being transferred to must either be on the same page (internal) or be the top gate of a separate fault tree file (external).

Complemented Events – Complemented events can be input into fault trees by right clicking on the event in the fault tree editor, then selecting “complement”. Complemented events can be reverted to normal logic in the same manner.

Forbidden Characters – Do not use *, ?, \, @, /, or space in the naming SAPHIRE fault trees or basic events. Note that the “/” symbol is reserved to denote a complemented event.

6.4. Basic Event Symbols

Graphical toolbar symbol for different basic event types are shown below, which is then modified in the Basic Event Edit option.

Basic Event

A basic event represents a fault such as a hardware failure, human error, or an adverse condition. The standard PRA basic event shape of a circle signifies that the fault event does not require further development. A box is available to provide an area that contains the description of the basic event.

Stacked Basic Events

Stacked basic events consist of two or more basic events displayed in a fashion that represents a “table” of basic events. SAPHIRE allows up to eight basic events to be stacked within one group under a single gate. After that, an additional group of stacked basic events is created under the same gate. The logic used by the stacked events is dictated by the gate it is connected to in the fault tree. Note that the description for each basic event appears above its name and double clicking on the basic event will bring up the basic event editor.
Undeveloped Event

The undeveloped event denotes a basic event that is actually a more complex event that has not been further developed by fault tree logic. SAPHIRE treats this event no differently than a basic event.

House Event

The house event denotes a failure that is guaranteed to occur (TRUE) or never to occur (FALSE). Even though any basic event in SAPHIRE can be a house event, the calculation type dictates the analysis behavior (Section 4).

Undeveloped Transfer

The undeveloped transfer indicates that the event is complex enough to have its own fault tree logic developed elsewhere; however, the event has been treated as a basic event in the present fault tree.

6.5. Logic Gate Symbols

Graphical toolbar symbols for different gate types with corresponding cursors:

<table>
<thead>
<tr>
<th>AND Gate</th>
<th>Or Gate</th>
<th>N/M Gate</th>
<th>Transfer Gate</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="AND Gate" /></td>
<td><img src="image" alt="Or Gate" /></td>
<td><img src="image" alt="N/M Gate" /></td>
<td><img src="image" alt="Transfer Gate" /></td>
</tr>
</tbody>
</table>

AND Gate

All inputs to the AND gate must occur for failure to occur. Text symbols used to represent an AND gate include \( \cap \) and \( \cdot \).
**OR Gate**

Any one input to the OR gate will cause failure to occur. Text symbols used to represent an OR gate include $\cup$ and $+$. 

**N/M Gate**

This gate states that N of the M input events must occur for failure to occur. For a 2-of-3 gate, any combination of 2 of the 3 input events must occur.

**Transfer Gate**

This gate is used to link logic structures together without introducing any new logic of its own. The transfer gate indicates that logic is continued on a new page (or on the same page). The transfer gate name is the same as the gate name where the logic continues. When transferring to another page (a separate fault tree file), the gate being transferred to must be the top gate on the page. (Note that a top gate name must be the same as the fault tree name. Thus, the transfer gate name must be the same as the fault tree name.)

**NOT AND (NAND) Gate**

The output occurs if any one of the inputs does not occur (see example below). A NAND gate is converted into regular (non-complemented) logic by first complementing each input ($A \rightarrow /A$) and then changing the gate to an OR gate. Note in SAPHIRE that the “/” indicates a complemented event.
NOT OR (NOR) Gate

The output occurs if none of the inputs occur (see example below). A NOR gate is converted into regular (non-complemented) logic by first complementing each input (A → /A) and then changing the gate to an AND gate. Note in SAPHIRE that the “/” indicates a complemented event.

Delete Term Gate

This gate is used when the delete term process is required within fault tree logic versus accident sequence logic. The inputs to this gate are converted to success states and then ANDed to other logic in order to remove certain combinations. The success events do not show up in the resultant cut sets.
6.6. Beginning a Fault Tree Editing Session

6.6.1. Opening a New Fault Tree

Double click on the New Fault Tree text at the top of the Fault Trees list to open a new fault tree.

A new fault tree opens with a default OR gate as the top gate.
6.6.2. Opening an Existing Fault Tree

Double click on the desired fault tree in the Fault Tree List Panel, or highlight the fault tree; right click and choose Edit Logic from the pop-up menu.

6.7. Fault Tree Gates and Basic Events

How to add gates and basic events to the fault tree is discussed below.

6.7.1. Adding a Basic Event to a Fault Tree

Existing basic events are added by clicking on the basic event in the Basic Event List Pane and dragging it then dropping it onto the desired gate.

To add a new basic event to a fault tree gate use the Graphical Toolbar symbol for a basic event.

By clicking on this button, the cursor will change to the null cursor. The cursor will then change to the boxed basic event symbol when placed over a gate. Use a left mouse click to add the basic event under the gate. Once the basic event is added, the attributes of the basic event can be changed to one of the various types of basic events along with its graphical display (click Event Display Type).
6.7.2. Adding Logic Gates

By clicking on a gate icon, the cursor will change to a null cursor \( \bigcirc \). The cursor will change to the boxed gate symbol that represents the gate selected when placed over a valid insertion location (i.e., over a gate). Use a left mouse click to insert the gate.

Once the gate is inserted into the drawing it can now be edited to include a specific name and description by right clicking and selecting **Edit**.

To change its type to one of the various types of gates, click on the drop down gate type and select the appropriate gate type.

Complement of gates, such as NAND and NOR, are created by first adding the standard gate and then changed by right clicking and selecting complement from the menu.
6.7.3. Deleting Logic Gates or Events

To delete a gate or event, right click the gate or event and choose the **Delete** pop-up menu option. All of the “child” gates and events (those that are inputs to the selected item) are deleted with the selected item.

6.8. Fault Tree Main Menu

The fault tree main menu provides functions for editing and adjusting the view of the fault tree.

**File**
- **Save** – Saves the fault tree as it is currently configured
- **Save As...** – Save the fault tree as it is currently configured as a different name
- **View Expanded Model Types** – Adds all of the different phases’ events on one fault tree for review, but not modification.
- **Import Logic** – Load a fault tree file into the current fault tree
- **Export Logic** – Save the current fault tree as a *.ftl MAR-D file.
- **Export Image** – Save the fault tree image as a .bmp or .wmf file.
- **Page Setup** – Set up a page for printing the fault tree to
- **Print** – Print the fault tree
- **Exit** – Close the fault tree

**Edit**
- **Properties** – Change properties such as the name, description, or the flag set assigned to the fault tree
- **Undo** – Removes the last action taken on the fault tree
- **Cut** – Cut the selected item from the fault tree and save to clipboard
- **Paste** – Paste the item in the clipboard to the fault tree gate
- **Paste As** – Paste the item as a different name
**Complement** – Treat the event as a success event [its probability is 1-P(failure)]

**Select All** – Selects all items

**Move To Transfer** – Transfers to the logic of the transfer gate that is highlighted (internal or external)

**Insert**

Choose a gate or basic event to insert and click on an existing gate to insert it into the fault tree.

**View**

**Zoom In** – Increases the size of the tree in relation to the window by one increment

**Zoom Out** – Decreases the size of the tree in relation to the window by one increment

**Fit in View** – Make the fault tree graphic fit in the fault tree window

**Box Size** – Opens a selection for changing the gates and basic events box size to small, medium or large

**Stack Events** – Check to display the events as stacked under their gate

**Stack Transfers** – Check to stack transfers at the same level under a gate

**View Quick Edit** – Check to open the quick edit toolbar for use. Quick Edit allows editing basic events and gate names, descriptions and gate types without having to open the basic event editor.
6.9. Zooming

To enlarge or shrink the view of the fault tree, use the zoom toolbar options, or choose the equivalent option from the main menu.

<table>
<thead>
<tr>
<th>Toolbar option</th>
<th>Menu equivalent</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Zoom In" /></td>
<td>View → Zoom In</td>
<td>Enlarge the scale of the drawing by a step.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Out" /></td>
<td>View → Zoom Out</td>
<td>Reduce the scale of the drawing by a step.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom %" /></td>
<td>(none)</td>
<td>Enlarge or reduce the scale of the drawing to the step value selected combo box, where 100% is considered normal.</td>
</tr>
<tr>
<td><img src="image" alt="Fit In View" /></td>
<td>View → Fit In View</td>
<td>Size the drawing so that the entire drawing is visible in the window</td>
</tr>
</tbody>
</table>

Use the scroll bars to change the portion of the diagram displayed in the window.

6.10. Ending the Fault Tree Editing Session

To save the fault tree, from the Fault Tree Editor menu bar choose File → Save.

To save a duplicate of the tree, use File → Save As and enter the name and (optional) description of the fault tree as directed. Designate the fault tree as a main or sub tree.

To exit without saving, from the Fault Tree Editor menu bar choose File → Exit. Choose No to quit without saving.
6.10.1. Sample Fault Tree

Demo CCS Fault Tree with events stacked

6.11. Printing Fault Tree Graphics

- To print fault tree graphics, highlight fault tree(s) then select Publish ➔ Fault Tree Report. From the list select, “Fault Tree Graphics Report”

- Select the type of output via the radio button. SAPHIRE will print the fault tree(s) to the format selected (i.e., Rich Text Format [RTF]).
♦ Click the Publish button.

Or, with fault tree highlighted in the fault tree graphic editing mode, select File ➔ Print. This will send the fault tree directly to the default printer.

Three options are available:

◊ Fit to single page – prints fault tree on one page

◊ Grid paged format – prints fault tree in different segments

◊ Smart paged format – prints fault tree to optimize number of pages and logic structure
Section 7 introduces SAPHIRE basic event data entry and basic event probability calculation types.

7.1. Basic Event Terminology

Unique terms used in SAPHIRE Basic Event editing are discussed below.

7.1.1. Failure Model

SAPHIRE provides 22 unique calculation types to describe how the basic event succeeds or fails.

7.1.2. Developed Event

A developed event is an event in SAPHIRE that is either an event tree top or a fault tree top gate. Regular fault tree basic events are not considered developed events.

7.1.3. Delete Term

In SAPHIRE, the process known as “delete term” refers to the removal of sequence success cut sets from the list of failure cut sets when generating sequence cut sets. As an example of the “delete term”, consider a sequence where top event A is successful and top event B is failed. Any cut sets that would fail A will not be allowed in the cut sets for B, so those cut sets are removed from the sequence.

7.2. Modify Basic Events

♦ To enter basic event data, go to the “Basic Events” list on the List Panel.

♦ To add a new event, double click New Basic Event … at the top of the Basic Events list (or File ➔ New ➔ Basic Event).
To modify data for an existing event, double-click on the event you want to edit or highlight the basic event; right-click to invoke the pop-up menu and select **Edit Basic Event**.

### 7.3. Edit Basic Event Screen

Modifying a basic event displays the “Edit Basic Event” dialog.
The screen consists of name and description textboxes, a template event assignment checkbox with a dropdown list of default templates, and also shows the calculated probability in the upper right.

### 7.3.1. Basic Event Screen Navigation:

- Click on the field you want to edit. The text will become editable, or a drop down selection box will become available.
- To save event changes and close the event window, choose **OK**.
- To save event changes but continue editing the event, choose **Apply**.
- To quit without saving a changed event, choose **Cancel**.
- To create a new event based on the characteristics of the displayed event, rename the event and check the **Save As New** box, then choose **OK**.

### 7.3.2. Basic Event Name and Description

The name is the fundamental name used in the fault trees and event trees. A unique name must be specified for every basic event in the logic models. A maximum of 24 uppercase, alphanumeric characters may be entered. Embedded spaces are not allowed.

The description is a 120-character, uppercase or lowercase, alphanumeric field that provides brief, descriptive information.

### 7.4. Basic Event Failure Model

The first tab on the left of the Edit Basic Event dialogue is the Failure Model. The use and capabilities of this tab are discussed.
7.4.1. Event Template

If you wish to use another event’s information as a template for this basic event, select the name of the event from the drop-down list (Default Template). Then check the box next to the desired characteristics to be used by this basic event. By default, all of the template event characteristics are selected and not editable. Other characteristics not in the template can be edited.

7.4.2. Model Type

A basic event has one or more model types. Each model type can have its own description and failure model information. This field is non-editable.

7.4.3. Description

This is the basic event description for this model type. Often it is the same as the basic event’s main description.

7.4.4. Calculated Probability

The calculated probability that will be used for the basic event is listed in this field. Note that certain failure models (i.e., fail to operate [without repair] (3)) will show the calculated probability, based on failure model chosen, in the Calculated Probability field.
7.4.5. Process Flags

Process flags are primarily used to tell SAPHIRE how to solve event tree accident sequences and fault tree logic. The process flag in the model type will cause the developed event (top event of any fault tree) to use the logic shown in Table 1 and Table 2. If the developed event is used as an Event Tree sequence top, the logic in Table 1 is used. If the developed event is used as a Fault Tree transfer, the logic in Table 2 is used.

Table 1. Sequence Top Process Flags

<table>
<thead>
<tr>
<th>Sequence Top Flags</th>
<th>BLANK or Default</th>
<th>Failure =&gt; System Logic</th>
<th>Success =&gt; Delete Term</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>When the Process Flag field is blank, the transfer associated with this event is expanded for failure references. For success branches in an event tree, the transfer is also expanded; however, the impossible cut sets are removed from the resulting cut sets using cut set matching (i.e., the delete term).</td>
<td></td>
<td></td>
</tr>
<tr>
<td>I</td>
<td>Failure =&gt; System Logic</td>
<td>Success =&gt; /System Logic</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Use system logic (if top event fails), use the complement of the system logic (if top event succeeds). That is, if the top event is a failure, SAPHIRE will expand the fault tree and solve, just as one expects. If the top event succeeds, SAPHIRE will complement the fault tree logic and solve it, thereby resulting in a non-coherent logic solution.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>W</td>
<td>Failure =&gt; System Logic</td>
<td>Success =&gt; /Developed Event</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Use system logic (if top event fails), use complement of the developed event (if top event succeeds). That is, if the event fails SAPHIRE will expand the fault tree and solve. If the event succeeds, SAPHIRE will treat the top as a basic event (i.e., developed event) and use the complement of the event for the system probability.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Sequence Top Flags

| X | Failure => Developed Event  
Success => Delete Term  
Use developed event (if event fails), use cut set matching to eliminate cut sets (if event succeeds). That is, an "X" tells SAPHIRE that a basic event is to be used for failure probability, but a success top is to be treated the same as if the flag was blank. |
|---|---|
| Y | Failure => Developed Event  
Success => /Developed Event  
Use developed event (if event fails), use complement of developed event (if event succeeds). That is, a "Y" indicates that a transfer is to be replaced with its basic event for failed references and the complement of the event is to be used for success tops. If the top event is to be treated as a basic event (both for the up and down branch), then use a “Y” flag for the event. |

### Table 2. Sequence and Fault Tree Process Flags

#### Sequence and Fault Tree Logic Flags

| Any value other than "X" | Failure => System Logic  
Success => Delete Term  
When the Process Flag field is any value other than “X”, the transfer associated with this event is expanded for failure references. For success branches in an event tree, the transfer is also expanded; however, the impossible cut sets are removed from the resulting cut sets using cut set matching (i.e., the delete term). |
|---|---|
| X | Failure => Developed Event  
Success => Delete Term  
Use developed event (if event fails), use cut set matching to eliminate cut sets (if event succeeds). That is, an "X" tells SAPHIRE that a basic event is to be used for failure probability, but a success top is to be treated the same as if the flag was blank. |
7.4.6. Uses Template

To use another event's information as a template for only this model type, select the name of the event from the drop-down list. For single model projects, use Event Default Template instead.

7.4.7. Failure Model

The Failure Model contains a calculation type selection box. There are 22 unique calculation types identified as 1, 3, 5, 7, N, V, T, F, I, C, X, S, G, E, H, U, Y, D, A, R, Q and O and defined in Table 3. Choose the desired calculation type from the drop-down list. See Table 4 "Basic" failure model calculation types and Table 5 “Advanced” failure model calculation types for details.

7.4.8. Failure Model Parameters

When a failure model is selected, the screen will change to display the required input types for that model.

<table>
<thead>
<tr>
<th>Calculation Type</th>
<th>Parameters*</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mean Failure Probability</td>
</tr>
<tr>
<td>3</td>
<td>Lambda** (per hour), Mission Time*** (hours)</td>
</tr>
<tr>
<td>5</td>
<td>Lambda* <em>(per hour), Tau (hours), Mission Time</em>** (hours)</td>
</tr>
<tr>
<td>7</td>
<td>Lambda** (per hour), Tau (hours)</td>
</tr>
<tr>
<td>C</td>
<td>Library and Procedures</td>
</tr>
<tr>
<td>V</td>
<td>Value</td>
</tr>
<tr>
<td>N</td>
<td>Frequency, Frequency Units (initiating event)</td>
</tr>
<tr>
<td>G</td>
<td>Median Failure Acceleration, Screening G-Line</td>
</tr>
<tr>
<td>H</td>
<td>Median Failure Acceleration</td>
</tr>
<tr>
<td>X</td>
<td>SPAR-H Diagnosis, Action, and Dependency Parameters</td>
</tr>
<tr>
<td>A,Q,R</td>
<td>CCF Properties Edited in model data****</td>
</tr>
<tr>
<td>E,S,I,T,F,U,Y,D,A,O</td>
<td>None</td>
</tr>
</tbody>
</table>

Notes:
* Uncertainty parameters will become available depending on the uncertainty distribution selected
** The time units of lambda, tau, and mission time are forced to be the same so that they cancel (e.g., in time units of either hour or per hour).

*** If no mission time is specified (i.e., the mission time is zero), the default mission time specified in SAPHIRE Project ➔ User Settings ➔ Analysis options will be used.

**** See Risk Assessment of Operational Events Handbook (RASP) CCF Module

### 7.4.9. Uncertainty Distribution

For each failure model input, an associated uncertainty distribution can be defined. There are thirteen predefined distribution types available:

- Beta, chi-squared, constrained non-informative, dirichlet, exponential, gamma, histogram, lognormal, maximum entropy, normal, seismic lognormal, triangular, and uniform.

In addition to these predefined distribution types, user-defined histograms may be used.

The default distribution type is Point Value (i.e., it is a point estimate). Choose the desired distribution type from the drop-down list. The screen will change to display the required input types for the selected distribution type.

### 7.4.10. Correlation Class

Use to account for data dependencies among like events in the database. Enter up to 24 uppercase, alphanumeric values. A blank correlation class indicates that there are no data dependencies. When running the uncertainty analyses, the same sample value will be used for all basic events with the same correlation class.
<table>
<thead>
<tr>
<th>Calc Type</th>
<th>Equation</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>(P = p)</td>
<td>Simply a probability (or, possibly, a frequency in the case of an initiating event). Could represent a failure upon demand. (p) = probability, in the “mean probability” field</td>
</tr>
<tr>
<td>3</td>
<td>(P = 1 - \exp(-\lambda \cdot T_m))</td>
<td>Failure probability of an operating component without repair (non-demand failure mode) (\lambda) = mean failure rate, in the “lambda” field (T_m) = mission time, in “mission time” field</td>
</tr>
<tr>
<td>5</td>
<td>(P = \left(\frac{[\lambda \cdot \tau]}{1 + [\lambda \cdot \tau]}\right) \cdot \left(1 - \exp[-(\lambda + 1/\tau) \cdot T_m]\right))</td>
<td>Failure probability of an operating component with the possibility of repair following a failure. (\lambda) = mean failure rate, in the “lambda” field (\tau) = mean repair time, in the “tau” field (T_m) = mission time, in “mission time” field</td>
</tr>
<tr>
<td>7</td>
<td>(P = 1 + (\exp[-\lambda \cdot \tau] - 1)/\lambda \cdot \tau)</td>
<td>Failure probability of a standby component in a non-demand failure mode that is tested periodically. (\lambda) = mean failure rate, in the “lambda” field (\tau) = test interval, in the “tau” field</td>
</tr>
<tr>
<td><strong>T</strong></td>
<td>(P = 1)</td>
<td>House event TRUE, represents a failure.</td>
</tr>
<tr>
<td><strong>V</strong></td>
<td>(P = V)</td>
<td>The basic event is to be treated as a value event. This calculation type is used in order to include events that take on values instead of probabilities. Therefore, the value can be greater than 1.0.</td>
</tr>
<tr>
<td><strong>I</strong></td>
<td>(P = 0)</td>
<td>The basic event is to be treated as if it did not exist in the logic for the fault tree. Before the tree is solved, all references to the specified event are removed from the fault tree.</td>
</tr>
<tr>
<td><strong>F</strong></td>
<td>(P = 0)</td>
<td>House event FALSE, represents a success.</td>
</tr>
</tbody>
</table>
### Table 5 “Advanced” failure model calculation types

<table>
<thead>
<tr>
<th>Calc Type</th>
<th>Equation</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>N</strong></td>
<td>( P = N \ (N &gt; 0) )</td>
<td>The basic event is to be treated as an initiating event frequency. This can be any positive value.</td>
</tr>
<tr>
<td><strong>R</strong></td>
<td>Common Cause Calculation</td>
<td>A calculation to represent CCF using the method identified in the RASP handbook.</td>
</tr>
<tr>
<td><strong>A</strong></td>
<td>RASP-based train level common cause calculation</td>
<td>CCF on a train-level basis with multiple components in each train (not yet implemented)</td>
</tr>
<tr>
<td><strong>Q</strong></td>
<td>RASP-based initiating event common cause calculation</td>
<td>A calculation to represent initiating event (per year) common cause failures (required for component assessments used in initiating events).</td>
</tr>
<tr>
<td><strong>U</strong></td>
<td>( P = 1 )</td>
<td>House event for common cause calculation when using the RASP method where it is unknown if the component is independent</td>
</tr>
<tr>
<td><strong>Y</strong></td>
<td>( P = 1 )</td>
<td>House event for common cause calculation when using the RASP method where the component is identified as independent</td>
</tr>
<tr>
<td><strong>D</strong></td>
<td>( P = 1 )</td>
<td>House event for common cause calculation when using the RASP method where the component is identified as dependent</td>
</tr>
<tr>
<td><strong>C</strong></td>
<td>( P = \text{calculated probability} )</td>
<td>The basic event’s probability is calculated based on different equations within SAPHIRE (i.e., summation of two different basic events or common cause failure calculation performed within SAPHIRE).</td>
</tr>
<tr>
<td><strong>X</strong></td>
<td>( P = \text{calculated probability} )</td>
<td>This basic event is a human action and SAPHIRE has worksheets built in to calculate the human error probability based on performance shaping factors.</td>
</tr>
<tr>
<td>Calc Type</td>
<td>Equation</td>
<td>Comments</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>----------</td>
</tr>
<tr>
<td>S</td>
<td>[ P = \text{calculated probability} ]</td>
<td>Finds a fault tree with the same name and uses its current cut set min cut upper bound as the probability.</td>
</tr>
<tr>
<td>G</td>
<td>[ P = \Phi[\ln(g_{\text{specified}}/a)/Br] ]</td>
<td>The basic event is to be treated as a seismic event. The probability value for screening will be calculated using the “screening G-level” (ground acceleration) and median failure acceleration (fragility) specified by the user. Strictly for use only in seismic analyses.</td>
</tr>
<tr>
<td>H</td>
<td>[ P = \Phi[\ln(g_{\text{hazard}}/a)/Br] ]</td>
<td>The basic event is to be treated as a seismic event. The probability value for screening will be calculated using the highest G-level (ground acceleration) from the project’s “seismic hazard curve” and median failure acceleration (fragility) specified by the user. Strictly for use only in seismic analyses.</td>
</tr>
<tr>
<td>E</td>
<td>[ P = \text{calculated probability} ]</td>
<td>Finds an end state with the same name and uses its cut set min cut upper bound as the probability</td>
</tr>
<tr>
<td>O</td>
<td>[ P = \text{calculated probability} ]</td>
<td>Uses convolution calculator based on mission time and input parameters (i.e., basic events)</td>
</tr>
</tbody>
</table>

Notes: \( \Phi = \text{standard normal cumulative distribution function} \)
\( a = \text{median failure acceleration (the approximate ground acceleration sufficient to cause the component to fail)} \)
\( Br = \text{amount the failure acceleration } "a" \text{ can vary} \)
\( g = \text{ground acceleration for screening} \)

### 7.5. Basic Event Attributes

Each basic event has special attributes that delineate the type of event. The Attributes tab opens the dialogue for setting or viewing these attributes.
7.5.1. Template Event

‘Template Event Check Box’ – If checked, then the event’s probability, attributes, and other information can be used by other basic events. This box does not indicate that the event is using template data. It is used to indicate that the data in this event can be used by other basic events.

7.5.2. Event Types:

Select from the drop-down list to specify the category or use of the event.

**General event** - This is the default and is appropriate for most basic events.

**Hazard event** - A special type assigned to histogram bins for seismic analysis.

**Initiating event** - Any initiating events should be identified with this category designation. The event tree editor will automatically enter an 'I' when the user specifies that the first event is an initiating event.

**Recovery event** – Generally not used.

**Factor Event** - A special type to be assigned to basic events representing alpha factors used in CCF calculations (reserved for future use).
7.5.3. Event Display Types:

Select from the drop-down list to specify the visual representation of the event for Fault Trees.

**Standard Event** – This is the default and is appropriate for most basic events.

**House Event** – This is an event that is either true or false and is usually set by Flag Sets or Change Sets.

**Undeveloped Event** – Typically a gate or an event set to a probability of one as a placeholder for an event that will have a failure model assigned in the future.

**Undeveloped Transfer** – This is another placeholder event that is a transfer event that has not been assigned a tree to transfer to yet.

7.5.4. Event Categories

Optional event categories can be defined for the project through MAR-D download or manually entered through Project ➔ Categories. These categories are used in Significance Determination Process (SDP) analyses. If event categories have been defined for the project, click on the “Name” column for each category and select the desired value.

7.6. Basic Event Applicability

The Applicability tab opens the dialogue to select the applicable model types and phase(s). By default only one model type is selected. If more than one model type or a Phase is selected, “Failure Model” data that is separately applicable to each model type must be entered.
7.7. Basic Event Notes

The Notes tab allows entry of notes and references related to the basic event that can be included in reports.
7.8. Basic Event Summary

The Summary tab provides a summary of the basic event, including uncertainty (if uncertainty parameters have been specified).
7.9. Editing a Basic Event

When editing a basic event, the type of failure model needs to be selected depending upon the component of interest. (The two dominant failure models will be discussed.)

7.9.1. Demand Related Failure Model (i.e., fails to start, fails to open)

The Failure Probability (1) failure model drop option needs to be selected, then type in the failure probability for the component (as shown below its demand failure probability is 1.0E-04). The uncertainty information can now be added at this time (uncertainty distributions will be covered in Section 9). Once all of the information has been input, select the OK option to save and close the basic event form. If you select the Apply option, SAPHIRE will update the information but not close the form.

7.9.2. Operating Related Failure Model (i.e., fails to run)

The Failure Probability (3) failure model drop option needs to be selected, and then type in the failure rate for the component (as shown below). When selecting this failure model, the mission time also needs to be input. SAPHIRE will calculate the failure probability (i.e., probability the component will fail prior to the mission time). The uncertainty information can now be added at this time (uncertainty distributions will be covered in Section 9). Select OK, to save the information.
Note: The uncertainty option for the mission time does not perform any sampling at this time; therefore, no information should be input into that field.

7.9.3. Save As New

Any basic event that has been previously saved can be modified and saved as a new basic event. Double click the basic event, change the name and description and then the analyst can utilize the same probability input parameters as a new basic event by selecting the “Save As New” check box.

This will save the basic event as a new basic event without having to add all of the input parameters to this new basic event. However, if you change the name of a basic event and fail to check the “Save As New” check box, the newly named basic event will over-right the original basic event with this new event name everywhere it is used.
7.9.4. Template Events

Template events are basic events that can be shared. For example, if a PRA contains 15 individual motor operated valve (MOV) basic events that fail to open, one can refer to a single template MOV-CC instead of typing the MOV failure rate information 15 times. Template events can be set up so that the event description, failure data, uncertainty data, attributes, and/or process flags can be used multiple times.

To create a template event, double click on **New basic event** in the Basic Events window to open the Basic Event form (or **File → New → Basic Event**).

- Input the basic event description, failure data, and uncertainty data that are associated with this template.
- To make SAPHIRE use this event as a template event, select the **Template Event** check box.
Now, click the **Attributes** tab. You will need to indicate which information is to be shared by this template event. If a box is checked in the **Avail For Use** (see below) then that information *will* be shared, otherwise, the description, event types and display types can be different in the event using the template information from what is specified here and only the failure model information is shared.

![Template Event](image)

**Note:**
One generally does not want to share the description since the events that use the template will have (possibly) unique descriptions.

To use a template event:

♦ Open the basic event edit window that will use the template event. (In the illustration below, basic event C-MOV-CC-A was selected).
The template can be assigned by clicking on the Default Template down arrow to list all of the template events in the database. Select the applicable template event.

Now, basic event C-MOV-CC-A will use the MOV-CC information that is indicated by the checked boxes.

If desired, information from the template event can be ignored by un-checking any of the applicable check boxes.

If a box is unchecked, the user will need to supply that information. For example, if the template failure rate “lambda” is not used, the failure rate would need to be specified just like a traditional basic event. In the case of the C-MOV-CC-A event from the DEMO project, it will revert to the original values entered for this basic event.

The yellow highlighted data fields with the check marks in the boxes next to them represent the information that was carried over from the template event. This information cannot be modified unless you deselect the particular input field by un-checking the box.

The advantage of using template events is if a parameter changes, the parameter only has to be changed once at the template event. Then, all the basic events using the template event will be updated automatically.
Section 8 describes how to generate fault tree cut sets. Model preparation prior to generating cut sets is discussed, and the various analysis and truncation options are described. Cut set display features are also presented.
8.1. Prerequisites for Generating Fault Tree Cut Sets

- Fault tree logic was created by using the fault tree graphics editor, or loaded into the database via the MAR-D interface.
- Basic event data were added through the Edit Basic Event forms (or MAR-D interface).
- Fault tree transfers are properly modeled so that there are no logic loops in the fault trees, there is only one top gate in each fault tree, and the naming of transfer gates and fault tree filenames is consistent.

Logic Loop Example

The correct way to "break the loop" will depend on which system is being analyzed.
8.2. Menus and options for fault tree cut set generation

- Use the mouse to select the Fault Tree(s) from the List Panel.
- Right-click to invoke the pop-up menu.
- Select the **Solve** option.

This option uses the fault tree logic from all fault trees that link to the top gate in the system. The fault tree probability is quantified using the Project Default.
8.2.1. Truncation Parameters

Select the desired truncation parameters and solution steps on the dialog, and choose Solve to begin generating cut sets.

Cut Set Truncation – From this combo box, choose one of the following options:

None – No truncation will be performed.

Global – uses the cutoff value in the adjacent cut off field. This field defaults to the value set in Project ➔ User Settings ➔ Analysis options ➔ Cut Set Truncation ➔ Fault Tree Value

System-specific – uses the cutoff value stored with the fault tree record (via the Edit ➔ Fault Tree, Edit ➔ Properties option).

Size Truncation – From this combo box, choose one of the following options:

Size – Cut sets having more than specified in the adjacent text box will be discarded.

Zone – Cut sets having more Zone Flagged Events than specified in the adjacent text box will not be retained.

None – The number of events in a cut set will not affect whether the cut set is retained or discarded.

8.2.2. Solution Steps

The Solution Steps area form includes options for rules application, cut set solving and Nominal Case update and/or Current Case clearing. Check one or more of the following boxes to indicate which steps should be performed. Options not available (i.e. no recovery rules have been set up) will be grayed out. The steps will be performed in their logic order from top to bottom.

Solve for Cut Sets – If you check this box, the fault tree logic will be solved for minimal cut sets using the truncation options specified.

Apply Post-processing Rules – If you check this box, any post-processing rules associated with this fault tree will automatically be applied after the fault tree cut sets have been generated.
Update / Quantify Cut Sets – When this box is checked, the cut sets will be reduced using Boolean algebra and then re-quantified using the truncation options specified. This option is useful for eliminating non-minimal cut sets introduced when post-processing rules have been applied, or to quickly re-quantify the cut sets when basic event data have been altered.

Quantify Cut Sets – When this box is checked, cut sets will be re-quantified using the truncation options specified.

Copy Cut Sets to Nominal Case – When this box is checked, cut sets will be saved as the nominal case.

Clear Current Case – When this box is checked, all data is cleared from the current case and the cut sets are eliminated.

Clear Current Case (All Models) – When this box is checked, all data is cleared from the current case and the cut sets are eliminated for all of the Model types in the project.

Copy Cut Sets to Nominal Case (All Models) – When this box is checked, cut sets will be saved as the nominal case for all of the Model types in the project.

8.2.3. Solve Quantification Methods

When Solve is clicked, the default quantification of the cut sets will be performed based on the selections made in the Project ➔ User Settings ➔ Analysis options ➔ Analysis Settings. Optionally, the Quantification Method selection can be made from the cut set solve form’s pull-down menu:

8.2.3.1. Minimal Cut Set Upper Bound Approximation

This calculation approximates the probability of the union of the minimal cut sets for the fault trees. The equation for the minimal cut set upper bound is
where:
S = minimal cut set upper bound for the system unavailability,
Ci = probability of the i'th cut set, and
m = the number of cut sets.

Example: If the cut sets for a system are A, B, C, the system unavailability computed from the minimal cut set upper bound approximation is
Pr(System) = 1 - [Pr(1 - A)*Pr(1 - B)*Pr(1 - C)].

8.2.3.2. Min Max Quantification

The Min-Max quantification option quantifies the current case cut sets using the exact probability quantification algorithm. From the example above, the exact system unavailability is

Pr(System) = [Pr(A)+Pr(B)+Pr(C)] - [Pr(A*B)+Pr(A*C)+Pr(B*C)] + [Pr(A*B*C)],

with the number of passes in this example being 3, corresponding to the number of pairs of parentheses.

8.2.3.3. Rare Event Approximation

This calculation simply sums each cut set as an approximation to the exact fault tree probability, [i.e., Pr(System) = Pr(A)+Pr(B)+Pr(C)].

8.2.4. Displaying Fault Tree Cut Set Results

♦ Highlight the fault tree in the List Panel that you want to view, right-click to invoke the pop-up menu.

♦ Select the View Cut Sets option.

8.2.5. Selecting Fault Tree Cut Sets to View

♦ The fault tree cut sets and minimal cut set upper bound approximations of the fault tree failure probability are now displayed.
To view the basic events in a cut set, click the “+” button for the cut set, or click the **Expand All** Button to view the basic events for all cut sets at once.

To find out where the events in the cut set came from, highlight a cut set and click on the **View Path** option.

The **Publish** button from the cut set screen allows you to print a cut set report.

The **Save End State** button allows you to store the list of cut sets in a user-defined end state.

The **Slice** button allows you to filter the list of cut sets based upon user-specified criteria. The cut sets can be filtered based on cutoff, basic events, attributes, or rules (refer to Section 15).
Notes
Section 9 describes uncertainty analysis for fault trees. The concept of performing uncertainty analysis via Monte Carlo or Latin Hypercube sampling is discussed.
9.1. Fault Tree Uncertainty Analysis

Uncertainty analysis calculates the variability of a fault tree top event probability resulting from uncertainties in the basic event probabilities.

SAPHIRE 8 provides two uncertainty analysis techniques:

Monte Carlo sampling

Latin Hypercube sampling

9.1.1. Monte Carlo Sampling

♦ A fundamental approach

♦ Makes repeated quantifications of the system cut sets using each random variable sampled from the basic event uncertainty distributions.

♦ Requires more samples than Latin Hypercube sampling for the same degree of accuracy.

9.1.2. Latin Hypercube Sampling

♦ A stratified sampling technique, with the random variable distributions divided into equal probability intervals.

♦ Probability is randomly selected from within each interval.

♦ May require fewer samples than simple Monte Carlo for similar accuracy; however, it may take longer to generate a random value than for a simple Monte Carlo sample.
9.2. Uncertainty Distributions for Basic Events

Basic event distribution types supported by SAPHIRE include:

<table>
<thead>
<tr>
<th>Distribution</th>
<th>Parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beta</td>
<td>$b$ in Beta$(a, b)$</td>
</tr>
<tr>
<td>Chi-squared</td>
<td>Degrees of freedom</td>
</tr>
<tr>
<td>Constrained Noninformative</td>
<td>(none)</td>
</tr>
<tr>
<td>Dirichlet</td>
<td>Beta value of success branch</td>
</tr>
<tr>
<td>Exponential</td>
<td>(none)</td>
</tr>
<tr>
<td>Gamma</td>
<td>$r$ in $\Gamma(r)$</td>
</tr>
<tr>
<td>Histogram</td>
<td>Histogram number</td>
</tr>
<tr>
<td>Lognormal</td>
<td>Error factor</td>
</tr>
<tr>
<td>Maximum Entropy</td>
<td>Lower and upper end point</td>
</tr>
<tr>
<td>Normal</td>
<td>Standard deviation</td>
</tr>
<tr>
<td>Point Value</td>
<td>(Use point estimate value only)</td>
</tr>
<tr>
<td>Seismic Log Normal</td>
<td>Beta $r$, Beta $u$</td>
</tr>
<tr>
<td>Triangular</td>
<td>Mode, Upper end point</td>
</tr>
<tr>
<td>Uniform</td>
<td>Upper end point</td>
</tr>
</tbody>
</table>

For example, a demand related basic event that uses a lognormal distribution.
SAPHIRE uses the inputs to determine the distribution of the component that will be used during the sampling process. The above basic event is a lognormal distribution and SAPHIRE will use the mean value and 95% Error Factor.

Correlation classes may be specified by the user to identify data dependencies. This dependency is based on similar components (i.e., check valves) using the same data that was derived from the same data source.

If the same correlation class (ID) is assigned to two different basic events with different inputs, SAPHIRE will give you an error message. What SAPHIRE is trying to do is create one distribution to sample from for all basic events that use that correlation class and if the inputs are different this won’t work and therefore, the error message.

SAPHIRE assumes a 100% correlation between basic events with the same correlation class.

9.3. Menus and Options for Performing Fault Tree Uncertainty Analysis

♦ Use the mouse to select a fault tree from the List Panel.

♦ Right-click to invoke the pop-up menu and select View Uncertainty.

The fault tree uncertainty screen will appear with the last calculated (if any) uncertainty results.
Uncertainty Calculation Values and Results

- To (re)calculate the uncertainty values, enter the following options and press Calculate.

- Input the Number of Samples. (A larger number of samples will provide more accurate results but will require more computation time.)

- Enter a value for the random number generator seed or accept the default. Enter zero to obtain a random seed from the system clock.

- Select one of the uncertainty method radio buttons, Monte Carlo or Latin Hypercube.

OPTIONAL:
To save intermediate sample results to a disk file for review, select an output format from the Intermediate Values combo box, and provide an output file name.
Notes
Section 10 describes the various fault tree importance measures available in SAPHIRE. Also, the calculations behind the importance measures are discussed.

10.1. Fault Tree Importance Measures

Importance measures provide “reliability-worth” information about basic events appearing in the cut sets for a fault tree.

Components showing high relative importance may be candidates for either (1) close monitoring to ensure that the component does not degrade over time or (2) design changes to increase the component reliability.

Ratio, Interval and Uncertainty importances are calculated for the highlighted fault tree cut sets.

**Ratio Importance** – Fussell-Vesely Importance, Risk Reduction Ratio, and Risk Increase Ratio.

**Interval Importance** – Birnbaum Importance, Risk Reduction Interval, Risk Increase Interval.

**Uncertainty Importance** – This importance measure provides information about the uncertainty of the component (i.e., those components that will contribute the largest uncertainty to an uncertainty analysis of the selected fault tree cut sets).
10.2. Definitions of the Importance Measures

**Fussell-Vesely Importance (FV)**

An indication of the fractional contribution of the basic event to the minimal cut set upper bound. The equation for FV importance (of the i’th basic event) is

\[ F_{Vi} = \frac{F_{i}(x)}{F(x)} \]

where:
- \( F(x) \) is the original minimal cut set upper bound
- \( F_{i}(x) \) is the minimal cut set upper bound with only the basic event of interest.

**Risk Reduction Ratio (RRR) or Risk Reduction Interval (RRI)**

An indication of how much the minimal cut set upper bound would decrease if the basic event probability were reduced (to a probability of 0.0. [i.e. never failed])

\[ \text{RRR} = \frac{F(x)}{F(0)} \]
\[ \text{RRI} = F(x) - F(0) \]

where:
- \( F(x) \) is the original minimal cut set upper bound
- \( F(0) \) is the minimal cut set upper bound with the event probability set equal to 0.0.

(Note the similarity between RRI and FV; the relative importance ranking of basic events will be the same for the two importance measures.)

**Risk Increase Ratio (RIR) or Risk Increase Interval (RII)**

An indication of how much the minimal cut set upper bound would increase if the basic event probability were increased (to a probability of 1.0).

\[ \text{RIR} (\text{RAW}) = \frac{F(1)}{F(x)} \]
\[ \text{RII} = F(1) - F(x) \]

where:
- \( F(x) \) is the original minimal cut set upper bound
- \( F(1) \) is the minimal cut set upper bound with the event probability set equal to 1.0.
**Birnbaum Importance (B)**

Indicates the sensitivity of the minimal cut set upper bound with respect to a change in the basic event probability.

\[ B = F(1) - F(0) \]

where:
- \( F(1) \) is the minimal cut set upper bound with the event probability set equal to 1.0.
- \( F(0) \) is the minimal cut set upper bound with the event probability set equal to 0.0.

**Uncertainty Importance (Standard Deviation)**

The uncertainty in each input parameter, as expressed through its probability distribution, contributes to the uncertainty in the output parameter of interest (e.g., core damage frequency, loss of mission). The uncertainty importance measure in SAPHIRE quantifies the contribution of each individual basic event’s uncertainty. SAPHIRE calculates the uncertainty importance using birnbaum importance and standard deviation as the appropriate approximation (see SAPHIRE Technical Reference NUREG/CR-7039 Volume 2):

\[ I_{unc} = \frac{\partial R}{\partial p_i} \sigma_i \approx I_{unc}(i) = B(i) \ast \sigma(i) \]

**Some useful importance measures relationships:**

- Birnbaum importance is equal to the sum of the RII and RRI importances.
  \[ B = RII + RRI \]
- Fussell-Vesely (FV) importance is equal to the product of the Birnbaum importance and the event probability, divided by the minimal cut set upper bound.
  \[ FV = (B \ast x)/F(x) \]
- RRI importance is equal to the product of the Birnbaum importance and the nominal basic event probability (RRI importance is sometimes referred to as the inspection importance).
RRI = B * x

- RII importance is equal to the product of the Birnbaum importance and the complement of the basic event probability.

$$\text{RII} = B \cdot (1 - x)$$

10.3. Importance Menus and Options

- Highlight the fault tree in the List Panel; right click to invoke the pop-up menu.
- Select View Importance Measures.

Viewing Importance Measures

- The importance measures are now displayed.

To sort by a column heading, click on the desired column heading. SAPHIRE then sorts the results for the selected importance measure in a descending order.

To perform uncertainty analysis for the importance measures, click the Sample button, enter the uncertainty sampling options, and press OK. The uncertainty details for each importance type are then available on their respective tab pages.

Choose Check All or click individual check boxes to select events to view on the Plot and Report tabs, which generate the report shown below (select Publish).
## Data

<table>
<thead>
<tr>
<th>Name</th>
<th>Pnt Est.</th>
<th>Mean</th>
<th>5th</th>
<th>50th</th>
<th>95th</th>
<th>Min</th>
<th>Max</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-CKV-CC-A</td>
<td>1.10E-4</td>
<td>1.14E-4</td>
<td>2.62E-6</td>
<td>2.97E-5</td>
<td>2.62E-4</td>
<td>5.11E-7</td>
<td>3.93E-3</td>
<td>ECS Trans A Discharge Check Valve Fails to Open</td>
</tr>
<tr>
<td>E-CKV-CC-B</td>
<td>1.10E-4</td>
<td>1.17E-5</td>
<td>1.09E-7</td>
<td>2.02E-6</td>
<td>3.43E-5</td>
<td>1.19E-4</td>
<td>1.14E-3</td>
<td>ECS Trans B Discharge Check Valve Fails to Open</td>
</tr>
<tr>
<td>E-COV-CC-A</td>
<td>7.69E-3</td>
<td>9.82E-3</td>
<td>1.40E-2</td>
<td>2.00E-2</td>
<td>2.20E-2</td>
<td>2.94E-1</td>
<td>2.56E-1</td>
<td>ECS Section Isolation Valve Fails to Open</td>
</tr>
<tr>
<td>E-COV-CC-B</td>
<td>1.10E-3</td>
<td>1.34E-3</td>
<td>2.84E-5</td>
<td>2.72E-4</td>
<td>2.70E-4</td>
<td>3.60E-4</td>
<td>2.44E-3</td>
<td>ECS Trans A Discharge MOV Fails to Open</td>
</tr>
<tr>
<td>E-MOV-CC-A</td>
<td>1.10E-4</td>
<td>5.48E-4</td>
<td>6.58E-7</td>
<td>8.60E-5</td>
<td>4.10E-4</td>
<td>8.41E-8</td>
<td>1.98E-1</td>
<td>ECS Trans B Discharge MOV Fails to Open</td>
</tr>
<tr>
<td>E-MOV-CC-B</td>
<td>1.10E-4</td>
<td>5.91E-4</td>
<td>4.60E-5</td>
<td>2.07E-4</td>
<td>1.28E-3</td>
<td>1.49E-2</td>
<td>1.34E-2</td>
<td>ECS Pump A Fails to Run</td>
</tr>
<tr>
<td>E-PMP-FR-A</td>
<td>5.57E-5</td>
<td>9.46E-5</td>
<td>1.56E-5</td>
<td>1.78E-5</td>
<td>2.08E-4</td>
<td>7.33E-8</td>
<td>6.47E-3</td>
<td>ECS Pump B Fails to Run</td>
</tr>
<tr>
<td>E-PMP-FR-B</td>
<td>5.59E-5</td>
<td>9.46E-5</td>
<td>1.56E-5</td>
<td>1.78E-5</td>
<td>2.08E-4</td>
<td>7.33E-8</td>
<td>6.47E-3</td>
<td>ECS Pump C Fails to Run</td>
</tr>
<tr>
<td>E-PMP-FS-A</td>
<td>1.32E-4</td>
<td>1.60E-3</td>
<td>3.19E-5</td>
<td>3.47E-4</td>
<td>3.61E-4</td>
<td>2.11E-4</td>
<td>7.32E-3</td>
<td>ECS Pump A Fails to Stop</td>
</tr>
<tr>
<td>E-PMP-FS-B</td>
<td>1.32E-4</td>
<td>4.47E-4</td>
<td>8.69E-7</td>
<td>2.06E-5</td>
<td>5.70E-4</td>
<td>1.00E-7</td>
<td>4.13E-2</td>
<td>ECS Pump B Fails to Start</td>
</tr>
<tr>
<td>S-DGN-FR-A</td>
<td>3.46E-1</td>
<td>7.97E-1</td>
<td>4.44E-1</td>
<td>7.95E-1</td>
<td>9.42E-1</td>
<td>2.03E-1</td>
<td>9.86E-1</td>
<td>Diesel Generator A Fails to Run</td>
</tr>
<tr>
<td>S-DGN-FR-B</td>
<td>2.34E-3</td>
<td>2.99E-3</td>
<td>3.02E-4</td>
<td>1.71E-3</td>
<td>4.43E-3</td>
<td>1.93E-4</td>
<td>3.09E-2</td>
<td>Diesel Generator B Fails to Run</td>
</tr>
<tr>
<td>S-DGN-FS-A</td>
<td>1.58E-1</td>
<td>1.92E-1</td>
<td>2.76E-2</td>
<td>1.39E-1</td>
<td>3.67E-1</td>
<td>7.18E-3</td>
<td>7.75E-1</td>
<td>Diesel Generator A Fails to Start</td>
</tr>
<tr>
<td>S-DGN-FS-B</td>
<td>4.32E-4</td>
<td>5.37E-4</td>
<td>3.50E-5</td>
<td>2.14E-4</td>
<td>1.16E-3</td>
<td>5.24E-6</td>
<td>1.26E-2</td>
<td>Diesel Generator B Fails to Start</td>
</tr>
<tr>
<td>S-TNK-FC-T1</td>
<td>9.47E-5</td>
<td>1.23E-4</td>
<td>1.83E-6</td>
<td>2.89E-5</td>
<td>2.72E-4</td>
<td>2.90E-7</td>
<td>5.22E-3</td>
<td>RWST Supply Fails</td>
</tr>
</tbody>
</table>

## Graph

![Importance Graph](image-url)
Section 11 describes SAPHIRE event tree linking and process required to link event tree sequences.

11.1. Linking Event Trees

"Linking" event trees is the process of generating sequence logic using the event tree graphical file.

Linking the event tree can be accomplished two ways:

♦ The sequences are generated automatically after the event tree is saved

♦ Manually linking by highlighting the event tree(s) in the List Panel, right-click mouse and select Link option

◊ Check the appropriate boxes and select the OK button. SAPHIRE will then generate all accident sequences based on the event tree logic.
Sequence Probability Cut Off

None

Generate sequence logic. This option is used for traditional event tree linking.

Normal (Use Split Fraction)

Generate sequence cut sets using the top events as split fractions. The sequence cut sets will be truncated based upon the cut off value specified. This truncation value will be used to truncate sequences where the value, including initiating event, is smaller than the specified value.

Conditional (Split Fraction/IE Frequency)

Generate sequence cut sets using the top events as split fractions. The sequence cut sets will be truncated based upon the cut off value specified. This truncation value will be used to truncate sequences where the value, based solely on the split fraction values, are smaller than the specified value.

Process Options

Create Logic Cut Sets

Will create a single cut set for the sequences if check box is checked. This cut set contains basic events representing each top event in the sequence. If not checked, then SAPHIRE will use the fault trees to generate cut sets (the traditional approach).

Limit Transfers? (Transfer Levels to Process)

A level is a transfer to another event tree (subtree). The default (99) will generate sequences for all subtrees. If the level is specified as less than 99, only that number of subtrees will be processed.
Mutually Exclusive Top Name

Generally left blank. This allows you to specify a top event (associated with a fault tree) that will be added to each sequence as a success event. The top will appear in the logic as a complemented system and will be treated accordingly when the sequence is solved. This method has been superseded by the link rules option.

Create Report?

This option will create a report displaying the sequence logic. Any substitutions will be displayed along with assigned flag sets and the resultant end state.

11.2. Unlinking Event Trees

The Unlink option quickly and easily removes the sequences. Linking can be re-accomplished at any time.

Unlinking is performed by invoking the pop-up menu by highlighting the event trees desired and right clicking, then selecting the Unlink option.
Notes
Section 12 describes how to generate event tree cut sets. Model preparation prior to generating cut sets is discussed, and the various analysis and truncation options are described. Cut set display features are also presented.

12.1. Prerequisites for Generating Event Tree Cut Sets

♦ Event tree logic was created by using the event tree graphical editor and saved.

♦ Event tree logic was “linked” (automatically performed when saved).

♦ Fault tree logic associated with the event tree logic was created using the fault tree editor and saved.

♦ Basic event data was added through using the **Edit Basic Event** form accessible through the Basic Events List Panel.

**Note:** Fault tree cut sets do not need to be generated prior to generating event tree sequence cut sets.

12.2. Menus and Options for Event Tree Cut Set Generation

♦ Highlight one or more event trees and/or sequences in the List Panel using the mouse.

♦ Right click to invoke the pop-up menu and select the **Solve** option.
12.2.1. Cut Set Generation Cutoff Values

Enter the desired truncation parameters and solution steps, and choose the Solve button to begin generating cut sets.

Cut Set Truncation – From this combo box, choose one of the following options:

None – No truncation will be performed.

Normal – uses the initiating event frequency in determining the cut off truncation value. This is the standard truncation option.

Conditional – ignores the initiating event value (i.e., assumes it is 1.0) thereby providing a conditional cutoff value (conditional upon the initiating event occurring).

Size Truncation – From this combo box, choose one of the following options:

Size – Cut sets having more than specified in the adjacent text box will be discarded.

Zone – Cut sets having more Zone Flagged Events than specified in the adjacent text box will not be retained.

None – The number of events in a cut set will not affect whether the cut set is retained or discarded.
12.2.2. Solution Steps, Current and Nominal Case

The Solution Steps area of the Solve Cut Sets form includes options for rules application, cut set solving and Nominal Case update and/or Current Case clearing. Check one or more of the following boxes to indicate which steps should be performed. Options not available (i.e. no post-processing rules have been set up) will be grayed out. The steps will be performed in their logic order from top to bottom.

**Solve for Cut Sets** – If you check box, sequence logic will be solved for minimal cut sets using the truncation options specified.

**Auto Post-processing Rules** – If you check box, any post-processing rules associated with the sequence(s) will automatically be applied after the sequence(s) cut sets have been generated. Generally, this box will be checked in parallel with Solve for Cut Sets.

**Update / Quantify Cut Sets** – When this box is checked, cut sets will be requantified using the truncation options specified. This option is useful for eliminating non-minimal cut sets introduced when recovery rules have been applied, or to quickly requantify the cut sets when basic event data have been altered.

**Quantify Cut Sets** – When this box is checked, cut sets will be requantified using the truncation options specified.

**Clear Cut Set Partitions** – This option provides a mechanism to remove end states from individual cut sets group that were previously assigned with Apply Partition Rules. This option is not necessary when Solve for Cut Sets has been checked, or for level 1 analysis.

**Apply Partition Rules** – This option provides a mechanism to group sequence cut sets into user specified end states based upon partition rules.

**Copy Cut Sets to Nominal Case** – When checked, this option will update the nominal case with the soon to be solved cut sets. The nominal case is the standard results for the model that current case analyses are compared to.
Clear Current Case – When this box is checked, all data is cleared from the current case and the cut sets are eliminated.

12.2.3. Displaying Event Tree Cut Set Results

♦ Highlight the event tree(s) or sequence(s) that you want to view in the List Panel.

♦ Right-click to invoke the pop-up menu and select the View Cut Sets option.

Once View Cut Sets is selected, as in the previous section, combined cut sets for the selected event tree sequences and minimal cut set upper bound approximation of their frequency are displayed.

To view the basic events in a cut set, click the button for the cut set, or click the Expand All Button to view the basic events for all cut sets at once. The basic events, their failure probabilities and descriptions are now displayed.
The **Publish** button from the cut set screen allows you to print a cut set report.

The **Save to End State** button allows you to store the list of cut sets in a user-defined end state.

The **Slice** button allows you to filter the list of cut sets based upon user-specified criteria (refer to Section 15).

The **Invert** button allows you to view the inverse of the sliced cut sets.

The **Explore Origin** button will parse the cut sets up into their original events and then rank them based on dominant contributors (more information about this option will be discussed in the Advanced SAPHIRE [manual] course).

The **Show End States** radio buttons add the **Partition defined** mapped end states for multiple level phased analyses and show the end states of the **Sequence** for single phase models.
12.3. Additional Event Tree Sequence Cut Sets Analysis Features

In complex PRA models, it may be necessary to use special features prior to cut set generation and/or after cut set generation. These features are addressed in the Advanced SAPHIRE course.

Prior to event tree sequence cut set generation:

♦ Flag Sets may be used to set House events or Process Flags on a sequence-by-sequence basis.

After event tree sequence cut set generation:

♦ Recover Cut Sets can be used as a rule-based automated way to add "recovery events" to the cut sets. These rules are a mechanism of post-processing the cut set list.
Section 13 describes uncertainty analysis for event tree sequences. The concept of performing uncertainty analysis via Monte Carlo or Latin Hypercube sampling is the same as discussed in the section on Fault Tree Uncertainty Analysis.

Uncertainty analysis calculates the variability of the sequence frequency resulting from uncertainties in the basic event probabilities and the initiating event frequency. SAPHIRE provides two uncertainty analysis techniques:

- Simple Monte Carlo sampling
- Latin Hypercube sampling

### 13.1. Menus and Options for Performing Sequence Uncertainty Analysis

- Highlight the desired event tree(s) or sequence(s) from the List Panel.
- Right click to invoke the pop-up menu and select **View Uncertainty**.
- If more than one event tree or sequence was selected, choose from the **Group By Event Tree(s)**, **Group**, or **Single Sequence(s)** submenu option to specify whether the marked event trees/sequences are to be calculated individually (one at a time), or as one or more groups.
The event tree/sequence uncertainty screen will appear with the last calculated (if any) uncertainty results graphed. If a single sequence or group was selected, a column of result values will also be displayed (shown below).

If **Single Sequence(s)** or multiple **Group By Event Tree(s)** was selected, a whisker plot summarizing each item will be displayed (shown below). In the case of the DEMO model, the Single Sequence(s) option will show:
13.2. Uncertainty Calculation Values

To (re)calculate the uncertainty values, enter the following options and press the Calculate button.

**Number of Samples** – Input the number of samples. (A larger number of samples will provide more accurate results but will require more time).

**Random # Seed** – Enter a value for the random number generator seed or accept the default. Enter zero to obtain a random seed from the system clock.

**Uncertainty Method** – Specify Monte Carlo or Latin Hypercube.

13.3. Uncertainty Results

✧ Press the Results Table button to view individual results (if calculated) and collective results in a tabular format.

✧ Uncertainty results (including graph) for each sequence when calculated individually can be also be viewed without having to recalculate:

✧ Highlight the single sequence in the List Panel.

✧ Right-click to invoke the pop-up menu and select the View Uncertainty option.
The individual sequence uncertainty previously calculated will be displayed and graphed.

Note:
Group uncertainty results are displayed only on the screen (as shown earlier in this section), and are not saved for later display.

Notes
Section 14 describes viewing importance measures for event tree sequences. A discussion of each type of importance measure is provided in Section 10 on Fault Tree Importance Analysis.

- Highlight the desired event tree(s) or sequence(s) from the List Panel.
- Right click to invoke the pop-up menu and select View Importance Measures.
- If more than one event tree or sequence was selected, the importance measures will be performed on the group automatically.
- To sort, click on the desired column heading. SAPHIRE then sorts the results for the selected importance measure in a descending order.
Check the boxes of the events interested in and click the Plot button underneath the top row of tabs to see a graphical representation of the importance measure based performing an uncertainty evaluation.

An html view report that combines the tabular and graphical results can be generated by clicking on the Report button.

Clicking on the Publish button allows creation of html, pdf, rtf, comma delimited or xls format reports.
Data

<table>
<thead>
<tr>
<th>Name</th>
<th>Point Est.</th>
<th>Mean</th>
<th>5th</th>
<th>95th</th>
<th>Min</th>
<th>Max</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C-PMP-FS-A</td>
<td>2.687E-8</td>
<td>2.598E-7</td>
<td>3.685E-11</td>
<td>1.739E-9</td>
<td>9.044E-7</td>
<td>2.176E-13</td>
<td>CCS Pump A Fails to Start</td>
</tr>
<tr>
<td>C-PMP-FS-B</td>
<td>1.159E-3</td>
<td>1.112E-3</td>
<td>2.795E-5</td>
<td>3.043E-4</td>
<td>2.529E-3</td>
<td>3.472E-6</td>
<td>CCS Pump B Fails to Start</td>
</tr>
<tr>
<td>E-PMP-FR-A</td>
<td>5.411E-4</td>
<td>5.748E-4</td>
<td>5.024E-5</td>
<td>2.590E-4</td>
<td>1.294E-3</td>
<td>1.293E-5</td>
<td>ECS Pump A Fails to Run</td>
</tr>
<tr>
<td>E-PMP-FR-B</td>
<td>5.431E-5</td>
<td>9.123E-5</td>
<td>1.333E-6</td>
<td>1.787E-5</td>
<td>1.902E-4</td>
<td>1.186E-7</td>
<td>ECS Pump B Fails to Run</td>
</tr>
<tr>
<td>E-PMP-FS-B</td>
<td>1.294E-4</td>
<td>4.268E-4</td>
<td>8.944E-7</td>
<td>2.207E-5</td>
<td>5.707E-4</td>
<td>5.194E-8</td>
<td>ECS Pump B Fails to Start</td>
</tr>
</tbody>
</table>

Graph

Importance Graph
Section 15 describes the cut set display feature that allows you to “slice” cut sets into different lists based on user-defined sort criteria. The sliced lists may then be viewed, reported, or saved to an end state. The cut set slicing features is available for fault tree, sequence, or end state cut sets.
15.1. The View Cut Sets Option

The view cut sets option is available in the Fault Tree, Sequence, and End State list menus.

Highlight the desired fault tree, event tree (or individual sequences), or end states, right click and select the View Cut Sets option.

As an example, view the cut sets for LOSP sequence 3. It is assumed that cut sets have already been solved (truncation of 1.0E-15).

From the LOSP sequence 3 cut sets, the minimal cut set upper bound approximation frequency is seen as 1.81E-3 and there are a total of 313 cut sets.
Options are available by choosing a radio button at the bottom of the page to display cut set end states with partition definitions or to show the end state at the end of the sequence.

- One or more sequences or end states can be highlighted simultaneously to display their respective cut sets (as a group), only a single fault tree can be selected to display its cut sets.

- If multiple sequences or end states are selected, all the cut sets from the highlighted sequences or end states will be grouped together and displayed (remember sequences are mutually exclusive and success terms are not accounted for; therefore, the some cut sets may appear as being non-minimal when in fact they are not).

15.1.1. The Event Slice Option

The event slice option is used to subdivide the cut sets into two lists. This option allows you to specify individual or combinations of desired basic events to appear in the “included in slice” list of cut sets.

With the LOSP sequence 3 cut sets displayed, select \( \text{Slice} \) at the bottom of the cut set display window. A \text{Slice Cut Sets} window will be displayed. Select the Events radio button at the top of this form and a list of the basic events will display. Utilize the selection processes discussed below to set up the slice and then click on \text{OK} to perform the slice.
### 15.1.1.1. Selecting Events

The Slice Cut Sets editor provides several ways to select events for slicing.

- The cut sets displayed for selection are controlled by the View Events From drop-down menu.
  - **Original Cut Sets** – This is the default setting and displays just the events from the original solved cut sets for the fault tree, sequence or end state that is being viewed.
  - **Project** – Includes all the events in the project.
  - **Current Slice** – Shows the events that are part of the currently viewed slice.

- Individual events can be selected from the list of basic events by clicking on the checkbox of those of interest which enters a check in the box next to the event.

- Batch selection of events is accomplished by using an expression in the textbox **Regular Expression** then clicking ![Mask Mark] to place checkmarks in the checkboxes of the applicable events. Use an asterisk "*" for wildcard searches.
  - *PMP would place a checkbox in all of the events with PMP in them
  - E-* would place a check in all checkboxes of events that start with "E-"

- Use the buttons ![Cear All] and ![Mark All] as necessary.

### 15.1.1.2. Include Type

Once the events are selected, Include Type (column) chooses how to include the events. This is selected in the Event Property drop-down menu (or by selecting the test box in the Include Type column).

- **Normal** – This is the default selection and will include cut sets where the event exists in any manner, failed or complemented.

- **Failure** – This includes cut set paths where the basic event is failed, which is the typical logic in SAPHIRE.

- **Success** – This includes only the cut sets where the basic event is in its complemented state, which typically is a success state in SAPHIRE.

- **NOT** – This includes the cut set paths where the basic event selected does not exist in any manner.
15.1.1.3. Logic Options

- OR or AND criteria must be specified for the selected events by selecting the desired radio button.

- For example, if you want to find cut sets that contain any of multiple events selected, use the OR option.
- If you want to just include cut sets that contain every one of the multiple events selected, use the AND option.

15.1.2. Viewing Cut Set Slices

At this point, a list of the cut sets meeting the event slice criteria will be displayed along with the quantified probability (or frequency), percent contribution to the total, and the number of cut sets meeting the event slice criteria.

As an example, the results shown are for a slice including all pump related events from LOSP sequence 3 cut sets that contain any of these basic events.

Expand the cut set by clicking on the icon to the left of the cut set to view events in a single cut set such as cut set #2 in the example.

The option allows you to copy the on-screen list of cut sets directly to a user-specified end state for further analysis or storage.

Click on the button to perform a slice on the currently displayed slice.

Use the option to show the cut sets that do not meet the current slice’s criteria.
Click on the **Publish** button to view and publish a report of the cut sets in .html, .pdf, or .xls format.

**15.2. The Cutoff Slice Option**

The cutoff slice option is used to display cut sets where truncation options will be used to parse the overall list of cut sets into two smaller lists.

With the LOSP sequence 3 cut sets displayed, select **Slice** to open the **Slice Cut Sets** editor, then select the **Cutoff** radio button.

- The **Top (Cut Sets)** option will parse the overall list of cut sets down to only the $X$ number of cut sets specified (i.e., if 25 is typed into the field, then only the top 25 cut sets will be displayed).

- The **Top (%)** option will parse the overall list of cut sets down to only the $Y$ percent contributing cut sets specified (i.e., if 90% is typed into the field, then only the top 90 percent cut sets will be displayed).

- The **Value >=** option will parse the overall list of cut sets down to only those cut sets above the specified truncation level (i.e., if $1E-06$ is typed into the field, then only those cut sets above the truncation level of $1E-06$ will be displayed).
The % Contribution option will parse the overall list of cut sets down to only those cut sets that contribute $Z$ percent to the overall probability (i.e., if 5% is typed into the field, then only those cut sets that contribute at least 5% to the overall probability will be displayed).

The Size $\leq$ option will parse the overall list of cut sets down to only those cut sets that have less than or equal to the number of events entered into the text field.

With the desired cutoff option selected and the specific truncation level specified, select Ok.

The cut sets meeting the cutoff slice criteria are displayed along with the quantified probability (or frequency), percent contribution to the total, and the number of cut sets meeting the cutoff slice criteria. In this case the top 10 cut sets were selected.

15.3. The Attributes Slice Option

This option is planned for future expansion of SAPHIRE 8 capabilities.
Notes
Section 16 describes how to generate reports for a variety of information including basic event data, fault tree results, and event tree results stored in SAPHIRE.

16.1. Main Menu Publish Selections

There are five options for publishing reports from the SAPHIRE 8 main menu publish tab:

- The Project Report lists statistics of the numbers of event trees, fault trees, basic events, and gates.

- Basic Event Reports include listings, either all selected or sorted by type such as RASP CCF and HRA Events, uncertainty, and categories. The custom report option includes even more choices.

- Fault Tree Reports include fault tree lists, cut sets (broken down in several ways), linkage rules, post-processing rules, importance measures (overall or by component or operator action) and graphics. The custom report option includes even more choices.

- Event Tree Reports include event tree lists, cut sets, linkage rules, post-processing rules, event tree dominant results, dominant sequence results, importance measures (overall or by component or operator action) and graphics. The custom report option includes even more choices.

- End State Reports include end state lists, cut sets, post-processing rules, event tree dominant results, dominant sequence results, importance measures (overall or by component or operator action) and graphics. The custom report option includes even more choices.

Many reports can also be generated from dialogs throughout SAPHIRE 8 by clicking on the Publish button, when available, in the dialog window.
16.1.1. Options for all Reports

An important thing to remember is that only selected items in the corresponding list pane will be included in a report. As an example, all of the Standard Basic Events are highlighted in list pane for the Basic Event Listing report shown below:

Report formats are available in HTML, PDF, Rich Text Format, Comma Delimited, and Microsoft Excel (XLS) by selecting the corresponding radio button in the Format pane. RTF and XLS previews are not available for reports but clicking will create the document for review and saving or printing. The previews for PDF and Comma Delimited are shown below.
Note the standard PDF menu bar above the preview.

Comma Delimited publishes to a .txt file using your default text editor.
Rich Text Format will not open in the SAPHIRE preview screen. The analyst will have to select Publish and then SAPHIRE will open your default word processor (Word) and create a table containing the basic event information.
XLS will open in Microsoft Excel (once the analyst selects Publish). This view shows the Basic Event Listing report opened in Excel 2010 in compatibility mode, where it can be saved as .xls or .xlsx.

All reports have multiple options within the item class (Basic Events, Fault Trees, Event Trees, or End States) or entire Project. Each of the item classes has a customizable reports option. The illustration at right shows the custom report form. Add or subtract fields to the report by highlighting and then clicking the right arrow to add or left arrow to subtract. Click when satisfied with the choices.
Section 17 describes how to perform sensitivity studies including basic event data modifications, event tree, and/or fault tree logic changes. The use of Change Sets to make basic event data modifications is described.

17.1. Overview of Steps Involved in Performing a Fault Tree or Event Tree Sensitivity Analysis

If logic changes are to be made (e.g., adding a basic event, removing a basic event, changing an OR-gate to an AND-gate, removing/adding a branch on an event tree, etc...), make the changes using the appropriate logic editor.

If data changes are to be made, enter data modifications by either

♦ Changing the data "permanently" by using the Edit Basic Event form accessible through the Basic Events List Panel

♦ Changing the data "temporarily" using a Change Set (Basic Events)

Then, solve the Fault Tree and/or Event Tree cut sets and then perform SAPHIRE operations such as quantifying cut sets, displaying cut sets, and generating reports.

17.2. Permanent Modifications of Logic Models or Basic Event Data

♦ Fault tree and event tree logic can be “permanently” changed in the current project by using their respective editors. (Alternatively, the fault tree or event tree logic can be modified using the MAR-D module.)

♦ Making a permanent data change to Basic Events is accomplished by simply opening the Basic Event editor, changing the desired data and saving. This
updates the nominal data. (Alternatively, the basic event data can be modified using the MAR-D module.)

**Note:**
It is NOT recommended that permanent changes be used for sensitivity analyses. Be careful to work only in the Current Case when doing so and not update the Nominal Case inadvertently. It is safer to work with Change Sets or use the General Analysis workspace option (discussed in the Advanced SAPHIRE manual).

### 17.3. Change Sets: Making "Temporary" Data Changes

Change Sets are used to modify Basic Event data only. (Logic changes to the fault trees and/or event trees can be made using a General Analysis, which is discussed in the Advanced SAPHIRE manual.)

Change Sets can be created using Singles or Class entry. The Singles entry modifies individual Basic Events. Using Class entry allows “mask combination” wildcard searches to change multiple events at once. Singles and Class changes can be used in the same change set.

- If the Change Sets List Panel is not visible in the left hand side Lists Panel window, open it by clicking on the Main Menu **View ➔ Change Sets**.

- To create a Change Set, double-click on **New change set**... to open the Change Set Editor.
17.3.1. Singles Change Set Example

Change sets can be entered using Singles or Class events. A Singles type change set is illustrated in FAULT-TREE-1 below which increases the probability by a factor of 10. Note that any of the Failure Model data could be changed.

♦ Click on the Singles tab if it is not already active
♦ Click and drag Basic Event C-MOV-1 to the Singles window and drop
♦ Click on the event and then the failure probability which will open up the Values to be Applied for the event
♦ Click on Failure Model check box in the Values to be Applied and then change the probability
♦ As many events can be added and modified as needed in the same manner
♦ Name and describe the Change Set and click

Changes made using the Change Sets can be viewed through the report option
Main Menu Publish ➔ Project Report ➔ Change Sets.
17.3.2. Class Change Set Example

A Class type change set is illustrated in FAULT-TREE-2 below which changes all failure rates for the operating pumps in the DEMO project. The failure rate (lambda) is increased by a factor of 10 (i.e., from 2.1E-5/hr to 2.1E-4/hr) over a mission time of 24 hours.

♦ Click on the **Class** tab if it is not already active
♦ Click on the **Use Class Change Set** check box to activate
♦ Click on the **Name Mask** check box to activate

(The **Mask Combination** should read **Or**, note that **And** is available for masks as well)

♦ Enter ?-PMP-FR-* in the **Match Value** column next to the Name Mask

◊ ? and * are the wildcard symbols which will affect all events that start with “E(C)-PMP-FR-”. The ? is a placeholder and the * is everything. (The search criteria are case sensitive [i.e., CAPITILIZATION of events].)

♦ In the right-hand window, Click on the Failure Model check box underneath **New Value Options**
♦ Use the pull-down menu in the Value column next to Failure Model to choose **Fails to operate (without repair) (3)**
♦ Change **Lambda** value to 2.1E-4
♦ Change the **Mission Time** to 24
♦ Name and describe the Change Set and click **OK**
Changes made using the Change Sets can be viewed through the report option Main Menu **Publish ➔ Project Report ➔ Change Sets**.

### 17.3.3. Solving Fault Trees and Event Trees Using Change Sets

Results of Fault Tree and/or Event Tree cut sets generated from using one or more change sets are used to compare to the Nominal Case (i.e., compare the what ifs to the nominal model results). To generate the cut sets using the selected change sets, perform the following:

- To use a change set, click on the check box to the left of the change set name in the **Change Set List Panel**.

- Changes will be made in the order that they are selected and a number will appear next to the change set name. Lower numbers are applied first, with the successive change sets over-writing any changes to the same events affected by prior change sets.
In the two change sets created above, FAULT-TREE-1 and FAULT-TREE-2, there are no overlaps of basic event changes, so it does not matter which change set is applied first.

From this point, select the desired Fault Tree, Event Tree or any combination thereof to solve and view their cut sets as presented in the sections on Solving Fault Trees and Solving Event Trees.

Be careful not to update the Nominal Case when performing a sensitivity analysis!
Section 18 explains the use of archiving, integration, and the MAR-D module for transferring PRA model data. The different types of MAR-D files that contain model information and their file formats are introduced.
18.1. Archive Project Utility

“Back up often”. How many times have we heard that? It’s a good policy and the archive project utility is a simple way to perform a complete backup of a SAPHIRE project. When a project is archived, the complete project (in its current state) is stored as a .zip file in a location of the user’s choosing. This .zip file will open as a duplicate project in SAPHIRE just as a .sra file does.

Although SAPHIRE saves its current state (opened with the .sra file) after each change of a parameter, the archive .zip file takes a snapshot of the project at a point in time. Archiving is useful to guard against project corruption or to share the project with others.

To create an archive .zip file:
♦ Close any open windows within the project
♦ Open main menu **File ➔ Archive Project** and you will be given the option to archive with full documentation (files stored in all folders) or limited archive with all the data but no reports (files stored only in **SAPHIRE required** subfolders).
♦ Choose a file name and location.
♦ Then click **Save**.
18.2. Integrate Project Utility

Integrate Project provides comparison of the current project with another project and transferral of selected items from the compared project to the current one.

To integrate a project:

♦ Open main menu **File → Integrate Project**

♦ Choose the project either from a list of recently opened projects or browse for a file using the Browse button.

♦ Click on the Integrate button to compare the files

♦ The report will show the differences between the two projects
To transfer items from the compared project to the current project:

- As shown above, place check marks in the boxes next to Basic Events, Event Models, Fault Trees, and Event Trees desired for import into the current project.
- Click on **Update Current Project** to start the import and a verification window will open.

![Confirm Project Update Window]

- After reviewing the items to be added either click on **Perform Update** to add them to the current project or **Cancel** to exit.
18.3. The MAR-D Module

Models and Results Database (MAR-D) provides another interface to load or extract data files that define the PRA database. The files are in a "flat-file" or ASCII file format. This is the legacy module for transferring files and is still fully supported in SAPHIRE 8.

Typical uses of MAR-D include:

♦ Transfer PRA information between data bases
  
  Extracting MAR-D files from one SAPHIRE project and loading them (via MAR-D) into another SAPHIRE project. (The SAPHIRE project may be a new one or a previously existing project.)

♦ Import other PRA code information
  
  Formatting the model information from another PRA code to use MAR-D file formats and creating a SAPHIRE project by loading the files via MAR-D.

♦ Edit PRA files using a text editor
  
  Extracting MAR-D files from a SAPHIRE project, editing the files to make changes to the model or model descriptions, and loading those files (via MAR-D) back into the SAPHIRE project.

♦ Archiving PRA files
  
  Saving the MAR-D files for long term storage in a text format rather than the native binary SAPHIRE format.

18.3.1. MAR-D File Format

The MAR-D file text format and field descriptions are provided in SAPHIRE reference material (NUREG/CR-7039, Volume 7).

Some general MAR-D formatting rules are:

♦ Use UPPER CASE for event and model names, i.e., CCS, C-CV-A.

♦ Upper and lower case can be used for descriptive text fields.
♦ Entries longer than the allowed field length will be truncated.

♦ Commas are field delimiters in most formats; therefore, commas cannot be used in descriptive text fields.

♦ Leading or trailing "empty" spaces are allowed.

♦ An "*" denotes a comment field in most formats; however, " | " denotes a comment field in rule files.

♦ A single line should not exceed 250 characters in length.

♦ ^EOS is used to signal the separation of MAR-D input contained in a single file. For example, when fault tree logic for more than one fault tree is contained in a single file, the ^EOS signals that the data for the current fault tree is complete and that another fault tree follows.

♦ File storage will create a .MARD file extension and a subfolder to the location the .MARD file is stored.

The subfolder will contain the individual file extensions listed in the tables below. This hierarchy allows for easy loading and extraction of files.
18.3.2. MAR-D Load and Extract Menus

♦ The MAR-D menus are provided via the main menu File → Load/Extract option.

♦ The “Load” tab allows you to load MAR-D files.

Click on “Open” to browse for files available to load. The compatible files must have the designated extension (.MARD for the new format).

To load individual files, check the “Allow old formats” and open the subfolder which contains the individual files and these files are listed based on their designated file extensions (e.g. .BEA, etc...). The format must conform to MAR-D specification.

Expand the item list as necessary and place a check in the checkboxes of the available information and the correct file extensions located in the subfolder are automatically selected for loading.

Click “Process” to load the files.
The “Extract” tab allows you to save MAR-D files from the database to a storage drive.

To extract information from SAPHIRE, select the Extract tab then select what information you want extracted by checking the checkboxes.

Click “Save As” and select a filename and location to save the files.

The default name is usually the project name and the .MARD extension.

The default location is the project \Mard subdirectory.

Click “Process” and the files will be saved with a root .MARD filename and a subfolder named (filename)_Subs will be created with all of the individual file extensions, as described above.

When sharing the MAR-D information, it is necessary to share both the .MARD file and the subfolder with the individual file extensions.
# Mar-D File Descriptions and General Guidance for Usage

## Project Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Names/Description</td>
<td>.FAD</td>
<td>Not needed if defined in the &quot;receiving&quot; project.</td>
</tr>
<tr>
<td>Project Attribute File</td>
<td>.FAA</td>
<td>Descriptive, contains default mission time</td>
</tr>
<tr>
<td>Project Textual Information</td>
<td>.FAT</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>Project Post-processing Rules (event tree sequences)</td>
<td>.FAY</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Project Post-processing Rules (fault trees)</td>
<td>.FAS</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Project Partition Rules</td>
<td>.FAP</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Project User Defined</td>
<td>.FAU</td>
<td>Needed if feature is used. (Project information)</td>
</tr>
<tr>
<td>Project Category Information</td>
<td>.FAC</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Project Model Types</td>
<td>.MTD</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Project Event Tree Group</td>
<td>.EGD</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Project Phase Model</td>
<td>.PHD</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>

## Event Tree Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Tree Names/Descriptions</td>
<td>.ETD</td>
<td>Load prior to other event tree/sequence info.</td>
</tr>
<tr>
<td>Event Tree Attributes</td>
<td>.ETA</td>
<td>Usually needed (specifies initiating event – event tree correspondence).</td>
</tr>
<tr>
<td>Event Tree Graphics</td>
<td>.ETG</td>
<td>Load either this file or .ETL.</td>
</tr>
<tr>
<td>Event Tree Logic</td>
<td>.ETL</td>
<td>Load either this file or .ETG.</td>
</tr>
<tr>
<td>Event Tree Rules</td>
<td>.ETR</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Event Tree Textual Information</td>
<td>.ETT</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>Event Tree Post-processing Rules</td>
<td>.ETY</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Event Tree Partition Rules</td>
<td>.ETP</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>

## End State Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>End State Names/Descriptions</td>
<td>.ESD</td>
<td>Load prior to other end state information files.</td>
</tr>
<tr>
<td>End State Information</td>
<td>.ESI</td>
<td>Undefined MAR-D file.</td>
</tr>
<tr>
<td>End State Textual Information</td>
<td>.EST</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>End State Cut Sets</td>
<td>.ESC</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>
### Fault Tree Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fault Tree Names/Descriptions</td>
<td>.FTD</td>
<td>Load prior to other fault tree/event tree files.</td>
</tr>
<tr>
<td>Fault Tree Graphics</td>
<td>.DLS</td>
<td>Loads graphic and associated logic.</td>
</tr>
<tr>
<td>Fault Tree Logic</td>
<td>.FTL</td>
<td>Not needed if .DLS loaded. If .DLS is not used, then associated descriptions come from the .BED and .GTD files.</td>
</tr>
<tr>
<td>Fault Tree Cut Sets</td>
<td>.FTC</td>
<td>Generally not used since SAPHIRE can generate the cut sets.</td>
</tr>
<tr>
<td>Fault Tree Attributes</td>
<td>.FTA</td>
<td>Usually not needed.</td>
</tr>
<tr>
<td>Fault Tree Textual Information</td>
<td>.FTT</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>Fault Tree Post-processing Rules</td>
<td>.FTY</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>

### Basic Event Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Event Names/Descriptions</td>
<td>.BED</td>
<td>Load prior to other basic event information files.</td>
</tr>
<tr>
<td>Basic Event Rate Information</td>
<td>.BEI</td>
<td>Usually needed.</td>
</tr>
<tr>
<td>Basic Event Attribute Codes</td>
<td>.BEA</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Transformations</td>
<td>.BET</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Compound</td>
<td>.BEC</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Text</td>
<td>.BEN</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Category</td>
<td>.BECat</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Grade</td>
<td>.BEG</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event HRA</td>
<td>.BEH</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event RASP CCF</td>
<td>.BER</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Names</td>
<td>.BEDA</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Descriptions (Alternate)</td>
<td>.BEMT</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Basic Event Model Type</td>
<td>.BEMDA</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>(Attribute)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Basic Event Model Type</td>
<td>.BEMD</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>(Description)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Gate Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gate Description</td>
<td>.GTD</td>
<td>Descriptive information (will be needed for gate text to appear if .FTLs used instead of .DLSs).</td>
</tr>
<tr>
<td>Gate Attributes</td>
<td>.GTA</td>
<td>Usually not needed because the information is loaded via the .DLS or .FTL</td>
</tr>
</tbody>
</table>
### Sequence Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequence Names/ Descriptions</td>
<td>.SQD</td>
<td>Load prior to other sequence information files.</td>
</tr>
<tr>
<td>Sequence Cut Sets</td>
<td>.SQC</td>
<td>Not needed since SAPHIRE can resolve cut sets.</td>
</tr>
<tr>
<td>Sequence Attributes</td>
<td>.SQA</td>
<td>Needed to specify sequence-to-FLAG SETS relationships (if used).</td>
</tr>
<tr>
<td>Sequence Logic</td>
<td>.SQL</td>
<td>Not needed if event tree exists (can Link tree).</td>
</tr>
<tr>
<td>Sequence Textual Information</td>
<td>.SQT</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>Sequence Post-processing Rules</td>
<td>.SQY</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Sequence Partition Rules</td>
<td>.SQP</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>

### Change Set Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Set Description</td>
<td>.CSD</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>Change Set Information</td>
<td>.CSI</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Change Set Attributes</td>
<td>.CSA</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>

### Histogram Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Histogram Description</td>
<td>.HID</td>
<td>Descriptive information only.</td>
</tr>
<tr>
<td>Histogram Information</td>
<td>.HII</td>
<td>Needed if feature is used.</td>
</tr>
<tr>
<td>Histogram Attributes</td>
<td>.HIA</td>
<td>Needed if feature is used.</td>
</tr>
</tbody>
</table>

### Slice Information

<table>
<thead>
<tr>
<th>Mar-D File Description</th>
<th>Extension</th>
<th>General Guidance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slice Names and Descriptions</td>
<td>.SLD</td>
<td>Sliced (partitioned) group of cut sets name and descriptive information.</td>
</tr>
<tr>
<td>Slice Basic Events</td>
<td>.SLB</td>
<td>Sliced (partitioned) cut set basic events.</td>
</tr>
<tr>
<td>Slice Information</td>
<td>.SLI</td>
<td>General Slice (partition) information.</td>
</tr>
<tr>
<td>Slice Attributes</td>
<td>.SLA</td>
<td>General Slice (partition) information.</td>
</tr>
</tbody>
</table>
Note:
The guidance provided above is of a general nature and is intended to provide insights into when it is necessary to load the particular MAR-D file. However, the particular needs of the user and characteristics of the model will determine the optimal combination of MAR-D files that should be loaded.
SAPHIRE – The “Big Picture”

Develop Project Models  Produce Current  Perform Analysis  Final Product
(logic and data)    Case Data

Build Fault Trees
(Section 6)

Build Event Trees
(Section 5)

Modify Basic
Events
(Section 7)
- Probabilities
- Frequencies
- Uncertainties
- Descriptions

Generate Probabilities
(Sections 2 and 7)

Fault Tree Analysis
(Sections 8-10 and 17)

Fault Tree Development

Link Event Trees
(Section 11)

Sequence Analysis
(Sections 12-14 and 17)

Event Tree
Development

Report Results
- Graphical Output
  (Section 5 and 6)
- Basic Events
  (Section 7 and 16)
- Fault Trees
  (Section 15 and 16)
- Sequences
  (Section 15 and 16)

NOTICE

This report was prepared as an account of work sponsored by an agency of the United States Government. Neither the United States Government nor any agency thereof, nor any of their employees, makes any warranty, express or implied, or assumes any legal liability or responsibility for any third party’s use, or the results of such use, of any information, apparatus, product or process disclosed in this report, or represents that its use by such third party would not infringe privately owned rights. The views expressed in this report are not necessarily those of the U.S. Nuclear Regulatory Commission.
# CONTENTS

<table>
<thead>
<tr>
<th>CONTENTS</th>
<th>PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>INTRODUCTION</td>
<td>1</td>
</tr>
<tr>
<td>MAIN MENU AND NAVIGATION</td>
<td>3</td>
</tr>
<tr>
<td>BUILDING EVENT TREES</td>
<td>5</td>
</tr>
<tr>
<td>BUILDING FAULT TREES</td>
<td>7</td>
</tr>
<tr>
<td>BASIC EVENT DATA ENTRY</td>
<td>15</td>
</tr>
<tr>
<td>FAULT TREE CUT SET SOLVING</td>
<td>19</td>
</tr>
<tr>
<td>FAULT TREE UNCERTAINTY ANALYSIS</td>
<td>25</td>
</tr>
<tr>
<td>FAULT TREE IMPORTANCE ANALYSIS</td>
<td>27</td>
</tr>
<tr>
<td>LINKING EVENT TREE SEQUENCES</td>
<td>41</td>
</tr>
<tr>
<td>EVENT TREE SEQUENCE CUT SET SOLVING</td>
<td>43</td>
</tr>
<tr>
<td>EVENT TREE SEQUENCE UNCERTAINTY ANALYSIS</td>
<td>49</td>
</tr>
<tr>
<td>EVENT TREE SEQUENCE IMPORTANCE ANALYSIS</td>
<td>55</td>
</tr>
<tr>
<td>VIEWING CUT SETS</td>
<td>69</td>
</tr>
<tr>
<td>UPDATES AND VIEWING THE NOMINAL CASE AND CURRENT CASE</td>
<td>73</td>
</tr>
<tr>
<td>FAULT TREE AND EVENT TREE SENSITIVITY ANALYSIS</td>
<td>77</td>
</tr>
<tr>
<td>USING DATABASE FILES</td>
<td>89</td>
</tr>
</tbody>
</table>
NOTES
1 INTRODUCTION

Section 1 contains an introduction to the SAPHIRE Basics course workbook

This SAPHIRE Basics course workbook accompanies the SAPHIRE Basics training course manual. The workbook provides instructions for modeling exercises that will provide students with hands-on experience using fundamental SAPHIRE features. The workbook provides model information for the workshop problems, describes the exercises to perform, and provides the results that should be achieved during the exercises.

The SAPHIRE Basics training course manual and SAPHIRE Reference Manuals should be used to provide additional instructions as needed to perform the exercises.

The workshop exercises will focus on simplified versions of reactor and containment cooling systems. A diagram of these systems is shown in Figure 1. The event tree and fault tree models related to operation of these systems. Basic events with their associated failure data will be specified for the individual components from the reactor and containment cooling systems.
Figure 1. System diagram of the reactor and containment cooling systems for the workshop exercises. Note that electrical support system dependencies are shown in brackets ( ) below the respective components.
Main Menu and Navigation

Workshop Objectives

The Main Menu and Navigation workshop accompanies Sections 1 through 3 in the training manual. The workshop objective is to familiarize you with the menus and navigation of the SAPHIRE 8 software.

First step to using software is to install it. If you haven’t done so, install SAPHIRE 8 by following the instructions in Section 1.8 of the Basics training manual.

Once the software is installed and opened, it will present you with an option screen as per Section 2.1 of the Basics training manual. We will need to make a new project. To make a project:

1. Add a new project named WKSP-1 using the instructions for “Create New Project” found in Section 2.1. Note that if you do not select the “Create New Project” icon from the startup screen, you can optionally use the main menu path File → New → Project.

Now familiarize yourself with the navigation of the Main Menu toolbar by browsing through the headings. Details of each option can be found throughout Section 3 of the manual and should be referred to as needed throughout this course. (Open the DEMO-MODEL project in order to navigate the menu options.)
3 Building Event Trees

Workshop Objectives

The Building Event Trees workshop accompanies Section 5 in the Basics training manual. The workshop objective is to practice building event trees using the graphical event tree editor in SAPHIRE.

1. Verify the WKSP-1 project is selected. The currently selected project is shown at the top of the SAPHIRE window. If not already selected, select the new project WKSP-1 in the File → Open Existing Project menu or File → select from the previously opened projects shown at bottom of options (SAPHIRE stores the last eight open projects).

To build the event tree:

1. In the WKSP-1 project, reproduce the event tree shown in Figure 2 by using the event tree graphical editor. Follow the editor instructions in the Basics course instruction manual Section 5.

2. Use the Project → User Settings → General Display and Project → Phases to adjust the colors of the workspace items to your preference.

3. The event tree shown in Figure 2 should be named LOSP. The LOSP event tree will be used in other workshop sessions.
Figure 2. The Loss-of-Offsite Power (LOSP) event tree.
Building Fault Trees

Workshop Objectives

The Building Fault Trees workshop accompanies Section 6 in the Basics training manual. The workshop objectives are to practice building fault trees using the graphical fault tree editor.

Workshop Instructions

Using the Fault Tree Logic Editor create the ECS Fault Tree

1. In the WKSP-1 project, construct the ECS fault tree shown in Figures 3 through 6 using the fault tree graphical editor. **NOTE: that Figures 4 through 6 are NOT Sub Trees!** They are shown for convenience and can be viewed by right clicking on the gate and selecting “View as Top Gate”. Follow the instructions in the SAPHIRE Basics course instruction manual in Section 6.

   [The SUP-DGNA and SUP-DGNB need to be added as transfer gates or can be built into the fault tree logic and then highlight the gate and select “Convert Gate to Sub-Tree.” Figures 7 and 8 display the logic for these fault trees. These fault trees will be used in both the ECS and CCS fault tree.]

2. Practice using the fault tree graphical editor commands.

3. Use the Project → User Settings → General Display and Project → Model Types to adjust the colors of the workspace items to your preference.

4. DO NOT ADD THE BASIC EVENT PROBABILITIES this will be done in a later workshop.
NOTE that the actual position of the branches in the tree may be different based on the order you add them. SAPHIRE builds the fault tree left to right.

Figure 3. The emergency cooling system (ECS) fault tree.
Figure 4. Portion of the ECS Fault Tree with ECS-SUPPLY gate viewed as the top

Figure 5. Portion of the ECS Fault Tree with ECS-TRAIN-A gate viewed as the top with small boxes selected
Figure 6. Portion of the ECS Fault Tree with ECS-TRAIN-B gate viewed as the top with small boxes selected.

Figure 7. SUP-DGN-A Sub-Tree
Figure 8. SUP-DGN-B Sub-Tree

Sub Trees (Use the following option if you did not create SUP-DGNA or SUP-DGNB as transfer gates when initially built.)

1. In the WKSP-1 project, we will use the Diesel Generator A and Diesel Generator B to support both the ECS and CCS Fault Trees. SAPHIRE 8 will not allow the same gate name to be used in two different fault trees. One way around this would be to name the gates differently even though their inputs are identical. The other way is to create sub trees and use a transfer gate to call the appropriate tree. This is the option we will perform in this workshop.

2. Select the SUP-DGNA gate (left click the mouse) that is not a transfer gate in the ECS Fault Tree you have created. Right click the mouse and select the option that appears that says “Convert Gate to Sub-Tree”. Perform the same action on the SUP-DGNB gate and save the ECS Fault Tree. Figure 9 shows the ECS Fault Tree as it should now look.

3. The sub trees can be viewed by selecting “All” or “Sub Trees” from the pull-down menu in the Fault Trees pane along the left hand side of SAPHIRE 8. Figure 9 shows one of the newly created Sub Trees.
Using the Fault Tree Logic Editor create the CCS Fault Tree

1. In the WKSP-1 project, construct the CCS fault tree shown in Figure 10 using the fault tree graphical editor. Follow the instructions in the SAPHIRE Basics course instruction manual in Section 6.

2. For this tree, utilize the drag and drop feature for the basic event that has already been created. S-TNK-FC-T1 has already been created, therefore you can click on it in the Basic Events window and drag it to the CCS-Supply gate you create for CCS Fault Tree and drop it onto the gate. Practice using this and other fault tree graphical editor commands. The created sub-trees for SUP-DGNA and SUP-DGNB can also be dragged and dropped into the correct gate. They do not need to be created again.

3. DO NOT ADD THE BASIC EVENT PROBABILITIES this will be done in a later workshop.
NOTE the use of transfers to sub-trees SUP-DGNA and SUP-DGNB

Figure 10. CCS Fault Tree
| 5 | Basic Event Data Entry |

Workshop Objectives

The Basic Event Data Entry workshop accompanies Section 7 in the training manual. The workshop objectives are to practice entering basic event data into SAPHIRE via the Edit Basic Event form.

Workshop Instructions

1. In the WKSP-1 project, enter basic event data provided in Table 1 into SAPHIRE by selecting the corresponding event from the Basic Event list panel in the left-hand side of the SAPHIRE screen (template basic events can be created and used if wanted for all; however, at least one template basic event needs to be created as discussed below).

   Note that the value for LOSP is 2.3, which indicates that the initiating event occurs 2.3 times per unit time. Within this project, the assumed frequency units are per-year. The Frequency Units on the Attributes tab for LOSP should be set to per year. Thus, the frequency of LOSP is 2.3/yr.

2. Verify that the calculated value for each basic event matches the calculated value shown in the right most column of Table 1 for each corresponding basic event by highlighting all of the basic events and then select Publish → Basic Event Reports. Table 1 is a custom report that can be created (see Section 15 in Basics Training manual).

Template Events - create a check valve template event to be used by all of the check valve basic events in the project database.

1. Open the Add Basic Event form by clicking on New Basic Event at the top of the Basic Events list panel (or File → New → Basic Event).

2. Add a new basic event called ZT-CKV-CC and assign it the following information:
• Check the Template Event checkbox
• Failure probability = 1.0E-4
• Lognormal uncertainty distribution with an EF of 10
• Correlation class of “CKV-T1”
• Make sure these all of these boxes are checked so the information will be utilized
• Uncheck the description check box under the Attributes Tab.

3. Assign this template to all of the check valve basic events (one at a time)
   • List all the check valve events by entering “CKV” into the search textbox and click on Search
   • The 5 basic events including “CKV” will be listed (including the template event just created). You can open the basic event editor from these search results.
   • Once the basic event editor is open, click drop down box next to Default Template and select the ZT-CKV-CC template event.
Table 1. Basic event data.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Failure Model</th>
<th>Failure Probability</th>
<th>Lambda</th>
<th>Mission Time</th>
<th>Distr. Type</th>
<th>Uncert. Value</th>
<th>Correlation Class</th>
<th>Calculated Probability</th>
</tr>
</thead>
<tbody>
<tr>
<td>C-CKV-CC-A</td>
<td>CCS Train A Discharge Check Valve Fails to Open</td>
<td>1</td>
<td>1.0E-4</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>CKV-T1</td>
<td>1.000E-004</td>
</tr>
<tr>
<td>C-CKV-CC-B</td>
<td>CCS Train B Discharge Check Valve Fails to Open</td>
<td>1</td>
<td>1.0E-4</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>CKV-T1</td>
<td>1.000E-004</td>
</tr>
<tr>
<td>C-MOV-CC-1</td>
<td>CCS Suction Isolation Valve Fails to Open</td>
<td>1</td>
<td>2.0E-4</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>MOV-S1</td>
<td>2.000E-004</td>
</tr>
<tr>
<td>C-MOV-CC-A</td>
<td>CCS Train A Discharge MOV Fails to Open</td>
<td>1</td>
<td>1.0E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>MOV-T1</td>
<td>1.000E-003</td>
</tr>
<tr>
<td>C-MOV-CC-B</td>
<td>CCS Train B Discharge MOV Fails to Open</td>
<td>1</td>
<td>1.0E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>MOV-T1</td>
<td>1.000E-003</td>
</tr>
<tr>
<td>C-PMP-FR-A</td>
<td>CCS Pump A Fails to Run</td>
<td>3</td>
<td>2.1E-5</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>5</td>
<td>PMP-T2</td>
<td>5.039E-004</td>
</tr>
<tr>
<td>C-PMP-FR-B</td>
<td>CCS Pump B Fails to Run</td>
<td>3</td>
<td>2.1E-5</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>5</td>
<td>PMP-T2</td>
<td>5.039E-004</td>
</tr>
<tr>
<td>C-PMP-FS-A</td>
<td>CCS Pump A Fails to Start</td>
<td>1</td>
<td>1.2E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>PMP-T1</td>
<td>1.200E-003</td>
</tr>
<tr>
<td>C-PMP-FS-B</td>
<td>CCS Pump B Fails to Start</td>
<td>1</td>
<td>1.2E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>PMP-T1</td>
<td>1.200E-003</td>
</tr>
<tr>
<td>E-CKV-CC-A</td>
<td>ECS Train A Discharge Check Valve Fails to Open</td>
<td>1</td>
<td>1.0E-4</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>CKV-T1</td>
<td>1.000E-004</td>
</tr>
<tr>
<td>E-CKV-CC-B</td>
<td>ECS Train B Discharge Check Valve Fails to Open</td>
<td>1</td>
<td>1.0E-4</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>CKV-T1</td>
<td>1.000E-004</td>
</tr>
<tr>
<td>E-MOV-CC-1</td>
<td>ECS Suction Isolation Valve Fails to Open</td>
<td>1</td>
<td>2.0E-4</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>MOV-S1</td>
<td>2.000E-004</td>
</tr>
<tr>
<td>E-MOV-CC-A</td>
<td>ECS Train A Discharge MOV Fails to Open</td>
<td>1</td>
<td>1.0E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>MOV-T1</td>
<td>1.000E-003</td>
</tr>
<tr>
<td>E-MOV-CC-B</td>
<td>ECS Train B Discharge MOV Fails to Open</td>
<td>1</td>
<td>1.0E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>MOV-T1</td>
<td>1.000E-003</td>
</tr>
<tr>
<td>E-PMP-FR-A</td>
<td>ECS Pump A Fails to Run</td>
<td>3</td>
<td>2.1E-5</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>5</td>
<td>PMP-T2</td>
<td>5.039E-004</td>
</tr>
<tr>
<td>E-PMP-FR-B</td>
<td>ECS Pump B Fails to Run</td>
<td>3</td>
<td>2.1E-5</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>5</td>
<td>PMP-T2</td>
<td>5.039E-004</td>
</tr>
<tr>
<td>E-PMP-FS-A</td>
<td>ECS Pump A Fails to Start</td>
<td>1</td>
<td>1.2E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>PMP-T1</td>
<td>1.200E-003</td>
</tr>
<tr>
<td>E-PMP-FS-B</td>
<td>ECS Pump B Fails to Start</td>
<td>1</td>
<td>1.2E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>PMP-T1</td>
<td>1.200E-003</td>
</tr>
<tr>
<td>LOSP</td>
<td>Loss of Offsite Power</td>
<td>N</td>
<td>2.3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>LOSP-1</td>
<td>2.300E+000</td>
</tr>
<tr>
<td>S-DGN-FR-A</td>
<td>Diesel Generator A Fails to Run</td>
<td>3</td>
<td>8.9E-4</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>3</td>
<td>DGN-T2</td>
<td>2.113E-002</td>
</tr>
<tr>
<td>S-DGN-FR-B</td>
<td>Diesel Generator B Fails to Run</td>
<td>3</td>
<td>8.9E-4</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>3</td>
<td>DGN-T2</td>
<td>2.113E-002</td>
</tr>
<tr>
<td>S-DGN-FS-A</td>
<td>Diesel Generator A Fails to Start</td>
<td>1</td>
<td>4.0E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>3</td>
<td>DGN-T1</td>
<td>4.000E-003</td>
</tr>
<tr>
<td>S-DGN-FS-B</td>
<td>Diesel Generator B Fails to Start</td>
<td>1</td>
<td>4.0E-3</td>
<td></td>
<td></td>
<td>LOG NORMAL</td>
<td>3</td>
<td>DGN-T1</td>
<td>4.000E-003</td>
</tr>
<tr>
<td>S-TNK-FC-T1</td>
<td>RWST Supply Fails</td>
<td>3</td>
<td>1.0E-7</td>
<td>24</td>
<td></td>
<td>LOG NORMAL</td>
<td>10</td>
<td>TNK-T1</td>
<td>2.400E-006</td>
</tr>
</tbody>
</table>
Fault Tree Cut Set Solving

Workshop Objectives

The Fault Tree Cut Set Solving workshop accompanies Section 8 in the training manual. The workshop objectives are to practice generating fault tree cut sets, experiment with various truncation options, and display the cut set results.

Workshop Instructions

1. In the WKSP-1 project, view all fault trees by choosing “All” from the drop down menu at the top of the Fault Trees list panel.

2. Practice highlighting the fault trees by highlighting them individually, or highlight multiple fault trees by using the common Shift+Click or CTRL+Click operations.

3. Highlight just the ECS fault tree.

4. Right click the mouse and select Solve to generate fault tree cut sets.

Specify truncation parameters as shown to the right and press OK to generate cut sets.

Note that the Global parameters are set in the Project → User Settings → Analysis Options menu.
5. When cut set generation is complete, the Cut Set Generation Results window should display the following:

6. Click **Close** to close out the Cut Set Generation Results window. With the ECS fault tree still highlighted, right click the mouse and select the **View → Cut Sets** option. This option will default to show the current case cut sets generated. The pull down menu at the top-right of the window allows view of the nominal case or a comparison of the two. Compare the current case cut sets for ECS to those shown in Figure 11.
**Figure 11.** ECS fault tree cut set results (1E-10 truncation).
7. Repeat steps 3 through 6 for the CCS fault tree. Compare the cut sets for CCS to those shown in Figure 12.

8. If you wanted to, Publish and Print a hard copy report of the CCS fault tree cut sets using the ✔️ Publish button and choosing a format. Printing options are available from the published format.

9. If your fault tree cut set results do not match, proceed with Fault Tree “Debugging” Tips:

   Fault tree construction data entry errors or inappropriate truncation limits can cause problems that prevent cut set solving. Examples of typical problems include:

   - Incorrect failure probabilities, calculation types, or failure rates specified
   - Incorrect fault tree logic gates used (e.g., OR-gate instead of AND-gate)
   - Very low truncation limits combined with large models may take a long time to generate cut sets.

10. Looking at the results for the ECS and CCS fault trees, consider the following questions:

    What is the quantified value saying with regard to the individual system?
    What happens if the quantification method is changed (i.e., Min Cut versus Rare Event versus Min/Max)?
    What happens if the truncation is increased (i.e., 1E-6, 1E-5, or 1E-3)?
    What happens if truncation is lowered (i.e., 1E-15, 1E-20, or no truncation)?
    How would you determine appropriate truncation level and quantification method?

11. Rerun fault tree cut set analysis for each fault tree with the original workshop settings before going to next workshop.
Figure 12. CCS fault tree cut set results (1E-10 truncation).
NOTES
# Fault Tree Uncertainty Analysis

## Workshop Objectives

The Fault Tree Uncertainty Analysis workshop accompanies Section 9 in the Basics training manual. The workshop objectives are to perform uncertainty analyses and review the results.

## Workshop Instructions

1. In the WKSP-1 project Fault Tree List Panel menu highlight the ECS system, right mouse click, and select the View Uncertainty option. Enter the uncertainty calculation values as shown, and press OK to perform the uncertainty analysis. Note that we assume the fault tree cut sets were generated using a 1E-10 truncation.

2. Compare your results to Table 2. Repeat for the CCS fault tree. Note: The results shown in Table 2 were generated using Monte Carlo sampling with 3,000 samples and a random seed number of 12345.

3. Display results by clicking the Results Table button.
4. Vary the uncertainty method, number of samples, and seed. How might you decide on an appropriate number of samples?

5. Rerun uncertainty results with original workshop settings before going to next workshop.

### Table 2. CCS and ECS uncertainty results (cut set truncation of 1E-10).

<table>
<thead>
<tr>
<th>Current Case Name</th>
<th>Point Estimate</th>
<th>Cut Set Count</th>
<th>Mean</th>
<th>Median</th>
<th>Standard Dev.</th>
<th>5th</th>
<th>95th</th>
<th>Seed</th>
<th>Num of Samples</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCS</td>
<td>2.532E-02</td>
<td>28</td>
<td>2.548E-02</td>
<td>2.170E-02</td>
<td>1.540E-02</td>
<td>9.133E-03</td>
<td>5.479E-02</td>
<td>12345</td>
<td>3000</td>
</tr>
<tr>
<td>ECS</td>
<td>2.532E-02</td>
<td>28</td>
<td>2.548E-02</td>
<td>2.170E-02</td>
<td>1.540E-02</td>
<td>9.133E-03</td>
<td>5.479E-02</td>
<td>12345</td>
<td>3000</td>
</tr>
</tbody>
</table>
8 Fault Tree Importance Analysis

Workshop Objectives

The Fault Tree Importance Analysis workshop accompanies Section 10 in the training manual. The workshop objective is to perform importance measure analyses using the traditional measures defined within SAPHIRE.

Workshop Instructions

1. In the WKSP-1 project Fault Tree List Panel menu highlight the CCS system, right mouse click, and select the View Importance Measures option. The point estimates of all the importance measures are available from the first window.

2. The tabs on the top of the window (F-V, RIR, BB, RII, RRI, and Unc (Std. Dev) are for uncertainty around the point estimates covered in this section. An example is given following the point estimation exercises of steps 3 and 4.
3. To sort the results with respect to a specific importance measure, click on the desired column heading. For example, to sort for increasing Fussell-Vesely importance, click on the FV column heading. Compare your CCS importance measure results to:
   - Figure 13 sorted for the Fussell-Vesely (FV) measures,
   - Figure 14 sorted for the Risk Increase Ratio (RIR) importance measures,
   - Figure 15 sorted for the Uncertainty importance measures, and
   - Figure 16 sorted for the Birnbaum importance measures.

4. Repeat the steps above for the ECS system. Compare your ECS importance measure results to:
   - Figure 17 sorted for the Fussell-Vesely (FV) measures,
   - Figure 18 sorted for the Risk Increase Ratio (RIR) importance measures,
   - Figure 19 sorted for the Uncertainty importance measures, and
   - Figure 20 sorted for the Birnbaum importance measures.
**Figure 13.** CCS system ratio importance measure results sorted by Fussell-Vesely (cut set truncation of 1E-10).
Figure 14. CCS system ratio importance measure results sorted by risk increase ratio (cut set truncation of 1E-10).
Figure 15. CCS system uncertainty importance measure results sorted by Uncertainty (cut set truncation of 1E-10).
### Importance Measures - CCS (FT)

<table>
<thead>
<tr>
<th>Name</th>
<th>Count</th>
<th>Prob.</th>
<th>FV</th>
<th>RR</th>
<th>RRR</th>
<th>Birnb.</th>
<th>RII</th>
<th>RRI</th>
<th>Uncertainty</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S-DGN-FR-B</td>
<td>1</td>
<td>2.113E-02</td>
<td>8.346E-01</td>
<td>3.94E+01</td>
<td>5.917E+00</td>
<td>9.957E-01</td>
<td>9.747E-01</td>
<td>2.104E-02</td>
<td>1.56E-02</td>
<td>Diesel Generator...</td>
</tr>
<tr>
<td>S-DGN-FS-B</td>
<td>1</td>
<td>4.000E-03</td>
<td>1.580E-01</td>
<td>3.94E+01</td>
<td>1.183E+00</td>
<td>9.786E-01</td>
<td>9.747E-01</td>
<td>3.914E-03</td>
<td>2.935E-03</td>
<td>Diesel Generator...</td>
</tr>
<tr>
<td>C-MOV-CC-1</td>
<td>1</td>
<td>2.000E-04</td>
<td>7.898E-03</td>
<td>3.94E+01</td>
<td>1.008E+00</td>
<td>9.749E-01</td>
<td>9.747E-01</td>
<td>1.950E-04</td>
<td>4.813E-04</td>
<td>CCS Suction Is...</td>
</tr>
<tr>
<td>S-TNK-FC-T1</td>
<td>1</td>
<td>2.400E-06</td>
<td>9.478E-05</td>
<td>3.94E+01</td>
<td>1.000E+00</td>
<td>9.747E-01</td>
<td>9.747E-01</td>
<td>2.339E-06</td>
<td>5.775E-06</td>
<td>RWST Supply F...</td>
</tr>
<tr>
<td>C-PMP-FS-B</td>
<td>6</td>
<td>1.200E-03</td>
<td>1.324E-03</td>
<td>2.066E+00</td>
<td>1.001E+00</td>
<td>2.708E-02</td>
<td>2.704E-02</td>
<td>3.288E-05</td>
<td>8.021E-05</td>
<td>CCS Pump B Fa...</td>
</tr>
<tr>
<td>C-MOV-CC-B</td>
<td>6</td>
<td>1.000E-03</td>
<td>1.103E-03</td>
<td>2.066E+00</td>
<td>1.001E+00</td>
<td>2.708E-02</td>
<td>2.705E-02</td>
<td>2.723E-05</td>
<td>6.685E-05</td>
<td>CCS Tran B Di...</td>
</tr>
<tr>
<td>C-PMP-FR-B</td>
<td>6</td>
<td>5.039E-04</td>
<td>5.559E-04</td>
<td>2.069E+00</td>
<td>1.001E+00</td>
<td>2.708E-02</td>
<td>2.706E-02</td>
<td>1.372E-05</td>
<td>1.729E-05</td>
<td>CCS Pump B Fa...</td>
</tr>
<tr>
<td>C-CKV-CC-B</td>
<td>6</td>
<td>1.000E-04</td>
<td>1.103E-04</td>
<td>2.069E+00</td>
<td>1.000E+00</td>
<td>2.708E-02</td>
<td>2.707E-02</td>
<td>2.723E-06</td>
<td>6.684E-06</td>
<td>CCS Tran B Di...</td>
</tr>
<tr>
<td>S-DGN-AR-A</td>
<td>4</td>
<td>2.113E-02</td>
<td>2.340E-03</td>
<td>1.106E+00</td>
<td>1.002E+00</td>
<td>2.731E-03</td>
<td>2.673E-03</td>
<td>5.776E-05</td>
<td>4.373E-05</td>
<td>Diesel Generator...</td>
</tr>
<tr>
<td>S-DGN-FS-A</td>
<td>4</td>
<td>4.000E-03</td>
<td>4.429E-04</td>
<td>1.107E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.715E-03</td>
<td>1.093E-05</td>
<td>8.168E-06</td>
<td>Diesel Generator...</td>
</tr>
<tr>
<td>C-PMP-CC-A</td>
<td>4</td>
<td>1.200E-03</td>
<td>1.329E-04</td>
<td>1.106E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.727E-03</td>
<td>3.279E-06</td>
<td>8.088E-06</td>
<td>CCS Pump A Fa...</td>
</tr>
<tr>
<td>C-MOV-CC-A</td>
<td>4</td>
<td>1.000E-03</td>
<td>1.107E-04</td>
<td>1.106E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.728E-03</td>
<td>2.713E-06</td>
<td>6.740E-06</td>
<td>CCS Tran A Dis...</td>
</tr>
<tr>
<td>C-PMP-CC-A</td>
<td>4</td>
<td>5.039E-04</td>
<td>5.679E-05</td>
<td>1.106E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.729E-03</td>
<td>1.377E-06</td>
<td>1.743E-06</td>
<td>CCS Pump A Fa...</td>
</tr>
<tr>
<td>C-CKV-CC-A</td>
<td>4</td>
<td>1.000E-04</td>
<td>1.107E-05</td>
<td>1.106E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.730E-03</td>
<td>2.733E-07</td>
<td>6.740E-07</td>
<td>CCS Tran A Dis...</td>
</tr>
</tbody>
</table>

**Figure 16.** CCS system difference importance measure results sorted by Birnbaum (cut set truncation of 1E-10).
**Figure 17.** ECS system ratio importance measure results sorted by Fussell-Vesely (cut set truncation of 1E-10).

<table>
<thead>
<tr>
<th>Name</th>
<th>Count</th>
<th>Prob.</th>
<th>FV</th>
<th>RIR</th>
<th>RRR</th>
<th>Birnbaum</th>
<th>Rll</th>
<th>RRI</th>
<th>Uncertainty</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-MOV-CC-1</td>
<td>1</td>
<td>2.000E-04</td>
<td>7.398E-03</td>
<td>3.949E+01</td>
<td>1.008E+00</td>
<td>9.749E-01</td>
<td>9.747E-01</td>
<td>1.950E-04</td>
<td>4.813E-04</td>
<td>ECS Suction Isolati...</td>
</tr>
<tr>
<td>S-DGN-FR-B</td>
<td>4</td>
<td>2.113E-02</td>
<td>2.340E-03</td>
<td>1.106E+00</td>
<td>1.002E+00</td>
<td>2.731E-03</td>
<td>2.673E-03</td>
<td>5.776E-05</td>
<td>4.373E-05</td>
<td>Diesel Generator</td>
</tr>
<tr>
<td>E-PMP-FS-A</td>
<td>6</td>
<td>1.200E-03</td>
<td>1.324E-03</td>
<td>2.068E+00</td>
<td>1.011E+00</td>
<td>2.738E-02</td>
<td>2.704E-02</td>
<td>3.268E-05</td>
<td>8.021E-05</td>
<td>ECS Pump A Fails...</td>
</tr>
<tr>
<td>E-MOV-CC-A</td>
<td>6</td>
<td>1.000E-03</td>
<td>1.103E-03</td>
<td>2.068E+00</td>
<td>1.001E+00</td>
<td>2.738E-02</td>
<td>2.705E-02</td>
<td>2.723E-05</td>
<td>6.695E-05</td>
<td>ECS Train A Disch...</td>
</tr>
<tr>
<td>E-PMP-FR-A</td>
<td>6</td>
<td>5.039E-04</td>
<td>5.559E-04</td>
<td>2.069E+00</td>
<td>1.001E+00</td>
<td>2.738E-02</td>
<td>2.706E-02</td>
<td>1.372E-05</td>
<td>1.729E-05</td>
<td>ECS Pump A Fails...</td>
</tr>
<tr>
<td>S-DGN-FS-B</td>
<td>4</td>
<td>4.000E-03</td>
<td>4.429E-04</td>
<td>1.107E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.719E-03</td>
<td>1.093E-05</td>
<td>8.186E-06</td>
<td>Diesel Generator</td>
</tr>
<tr>
<td>E-PMP-FS-B</td>
<td>4</td>
<td>1.200E-03</td>
<td>1.329E-03</td>
<td>1.108E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.727E-03</td>
<td>3.279E-06</td>
<td>8.088E-06</td>
<td>ECS Pump B Fails...</td>
</tr>
<tr>
<td>E-MOV-CC-B</td>
<td>4</td>
<td>1.000E-03</td>
<td>1.107E-03</td>
<td>1.108E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.728E-03</td>
<td>2.733E-06</td>
<td>6.740E-06</td>
<td>ECS Train B Disch...</td>
</tr>
<tr>
<td>E-CKV-CC-A</td>
<td>6</td>
<td>1.000E-04</td>
<td>1.103E-04</td>
<td>2.068E+00</td>
<td>1.000E+00</td>
<td>2.730E-02</td>
<td>2.707E-02</td>
<td>2.723E-06</td>
<td>6.894E-06</td>
<td>ECS Train A Disch...</td>
</tr>
<tr>
<td>S-TNH-FC-T1</td>
<td>1</td>
<td>2.400E-06</td>
<td>9.476E-05</td>
<td>3.949E+01</td>
<td>1.000E+00</td>
<td>9.747E-01</td>
<td>9.747E-01</td>
<td>2.339E-06</td>
<td>5.770E-06</td>
<td>RWST Supply Fails</td>
</tr>
<tr>
<td>E-PMP-FR-B</td>
<td>4</td>
<td>5.039E-04</td>
<td>5.579E-05</td>
<td>1.100E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.728E-03</td>
<td>1.377E-06</td>
<td>1.735E-06</td>
<td>ECS Pump B Fails...</td>
</tr>
<tr>
<td>E-CKV-CC-B</td>
<td>4</td>
<td>1.000E-04</td>
<td>1.107E-05</td>
<td>1.108E+00</td>
<td>1.000E+00</td>
<td>2.730E-03</td>
<td>2.730E-03</td>
<td>2.733E-07</td>
<td>6.740E-07</td>
<td>ECS Train B Disch...</td>
</tr>
</tbody>
</table>
Figure 18. ECS system ratio importance measure results sorted by risk increase ratio (cut set truncation of 1E-10).
Figure 19. ECS system uncertainty importance measure results sorted by Uncertainty (cut set truncation of 1E-10).
Figure 20. ECS system difference importance measure results sorted by Birnbaum (cut set truncation of 1E-10).
5. Click on the F-V tab on the top row of the importance measures window. A sampling options window will open much like the one used in fault tree cut-sets uncertainty. Choose the default 3000 samples, 12345 random seed and Monte Carlo and click on Calculate. The following window will open. Click on the other importance tabs to view their uncertainty without the need to re-sample. Re-sampling can be accomplished at any time by clicking on Sample. Sorting can be accomplished the same as with the point estimates, by clicking the column header.

![Importance Measures - ECS (FT)](image)

Figure 21. ECS fault tree Fussell-Vesely importance with uncertainty measures

6. Now use the UnCheck All button and then just check the events that relate to the pumps (E-PMP-FR-A, E-PMP-FR-B, E-PMP-FS-A, and E-PMP-FS-B) by clicking on their checkboxes.
7. View the Importance uncertainty box plots for the pumps by clicking on the Plot tab and compare to the Figure 22.

![Importance Measures - ECS (FT)](image)

Figure 22. ECS Fussell-Vesely Importance Graph of pump components

8. Click on the Report tab and then click and drag the bottom right corner of the window to re-size it to view the html report shown in Figure 23. Note that you can publish reports in multiple formats as covered in the section on Fault Tree Cut Set Solving.
**Figure 23.** ECS Pump Components Fussell-Vesely Importance Measures report
NOTES
Linking Event Tree Sequences

Workshop Objectives

The Event Tree Linking workshop accompanies Section 11 in the training manual. The workshop objectives are to practice linking event trees and to be familiar with the event tree logic report format.

Workshop Instructions

1. In the WKSP-1 project Event Trees list pane highlight the LOSP event tree, right mouse click, and select the Link option.

2. Enter the desired “reporting” option on the pop up window. To view the linked event tree sequences logic report, select “Create Report” checkbox. The default entries for the remaining parameters (shown right) are acceptable for this event tree. Press OK to link the event tree sequences.

Note: After an event tree has been linked, the event tree logic can be obtained from Publish → Event Tree Report → Event Tree Sequence Logic menu option with the multiple formats available.
3. Review the event tree logic report that you generated; it should match the event tree logic report shown below. The convention used to depict the event tree sequence logic is that an event tree downward branch (failed) is indicated by the top name (CCS) and an upward branch (success) is indicated by the complemented top name (/CCS). Note that the columns are re-sizeable by clicking and dragging their edges.

![Event Tree Logic Report](image)

Question: Why did the logic for LOSP sequence 1 not get generated?

Answer: SAPHIRE ignores all sequences with OK or Success in the endstate name field.
10

Event Tree Sequence Cut Set Solving

Workshop Objectives

The Event Tree Sequence Cut Set Generation workshop accompanies Section 12 in the training manual. The workshop objectives are to practice generating event tree sequence cut sets, experiment with various truncation options, and display the cut set results.

Workshop Instructions

1. In the WKSP-1 project Event Trees list pane highlight the LOSP event tree, right mouse click, and select the Solve option.

2. The default truncation probability is set in the Global in the Project → User Settings → Analysis Options menu. It can be changed here manually.

3. Using all the default settings, click the Solve button to generate cut sets for the LOSP sequences.

   Note: Cut sets will not be generated for those sequences that are not highlighted.
4. When cut set generation is complete, a summary Solve Results window will appear with the overall value and number of cut sets. Select the `Cut Sets` button and the Cut Sets Results window should display. Both are shown below.
5. Click [Close] to close the two windows.

6. Click on the "±" next to the LOSP Event Tree. The LOSP sequences will show below it. Highlighting and selecting Solve for one (or more) sequences under the event tree solves only those sequences. To practice this procedure, highlight LOSP sequence 2, right mouse click, and select the Solve option with the default values. Compare the LOSP sequence 2 cut sets to those shown in Figure 24.

7. In actuality, the cut sets for each sequence were solved when we solved the entire LOSP Event Tree. Highlight LOSP sequence 3, right mouse click, and select the View Cut Sets option. Compare the LOSP sequence 3 cut sets to those shown in Figure 25.

8. Highlight LOSP, right mouse click, and select the View Summary Results option. Expand the results by clicking [Expand All]. Compare sequence results to those shown in Figure 26. Note the lack of uncertainty data. Sequence uncertainty will be covered in the next workshop.

9. Looking at the LOSP sequence results, consider the following questions:

   What is the quantified value saying with regard to each sequence, the LOSP event tree, and this project?
   What happens if the quantification method is changed (i.e., Min Cut versus Rare Event versus Min/Max)?
   Why are the sequence results different than just multiplying the sequence logic events?
   Sequence 2 = LOSP * ECS * /CCS = 2.3 * 2.532E-2 * 9.7468E-1 = 5.6761E-2
   Sequence 3 = LOSP * ECS * CCS = 2.3 * 2.532E-2 * 2.532E-2 = 1.475E-3
   Total = 5.8236E-2
   What happens if the truncation is increased (i.e., 1E-5, or 1E-3)?
   What happens if truncation is lowered (i.e., 1E-20, 1E-30, or no truncation)?
   How would you determine appropriate truncation level and quantification method?

10. If necessary, rerun the event tree sequence cut set generation for the LOSP sequences with the original workshop settings before going to next workshop. This is only necessary if the Update Cut Sets to Nominal Case was checked while solving the Current Case.
**Figure 24.** LOSP event tree sequence 2 cut sets (cut set truncation of 1E-13).
Figure 25. LOSP event tree sequence 3 (cut set truncation of 1E-13).
Figure 26. LOSP event tree sequence results (cut set truncation of 1E-13).
11

Event Tree Sequence Uncertainty Analysis

Workshop Objectives

The Event Tree Sequence Uncertainty Analysis workshop accompanies Section 13 in the training manual. The workshop objectives are to perform uncertainty analysis for individual sequences, for all sequences combined, and to report the uncertainty results.

Workshop Instructions

1. In the WKSP-1 project Event Trees list pane highlight the LOSP event tree, right mouse click, and select the View Uncertainty → Single Sequence(s) option. Click on Calculate with the default values to perform an uncertainty analysis for all sequences of LOSP. Note that we assume sequence cut sets were generated using 1E-13 truncation.

2. Click on Results Table and then on Expand All to compare your results to Figure 27 for LOSP event tree sequence 2 and sequence 3. Note that you will have to check and uncheck display boxes accordingly if you want to match the figure shown in Figure 27. These results can be published as covered previously.

3. Display results of a single sequence or any number of highlighted sequences from the Event Trees list pane menu by highlighting the sequence(s), right mouse click, and select the View Uncertainty option.
Figure 27. LOSP event tree sequence 2 and sequence 3 uncertainty results (cut set truncation of 1E-13).
4. To perform an uncertainty analysis on an entire project in the **Event Trees list pane** highlight all event trees.

In the WKSP-1 project we only have one event tree, so we will create a temporary event tree to illustrate this function. Double click on **New event tree ...** in the **Event Trees list pane** and create a tree called TEMP and save it. (No longer necessary in Version 8.1.3.)

Highlight the LOSP and TEMP event trees, right mouse click, and select the **View Uncertainty → Group** option. Click on **Calculate** with the default values to perform an uncertainty analysis for all sequences of the project. Note that we assume sequence cut sets were generated using 1E-13 truncation. The results are listed on the **Uncertainty for: Project** window.
5. Display results from the **Publish** menu by following the **Publish → Project Report → Uncertainty** option. The html format is shown below.

![HTML Viewer](image)

6. Vary the uncertainty method, number of samples, and seed. How might you decide appropriate number of samples?

   **Optional** Analyze one of the LOSP sequences varying the sample size and then plotting the mean value obtain for each sample size using a spreadsheet program. See Figure 28 is an example for Sequence 2. (Sequence 2 has 19 cut sets; approximately 0.01 seconds for sample size 100 and approximately 4.95 seconds for sample size 99,999.)

7. Rerun uncertainty results with original workshop settings before going to next workshop.
Figure 28. Convergence plot of the Sequence 2 mean value.
NOTES
Event Tree Sequence Importance Analysis

Workshop Objectives

The Event Tree Sequence Importance Analysis workshop accompanies Section 14 in the Basics training manual. The workshop objectives are to perform importance analysis for individual sequences, for all sequences combined, and to report the results.

Workshop Instructions

1. In the WKSP-1 project Event Trees list pane, expand the LOSP event tree list to show the sequences.

2. Perform the importance analysis on each individual sequence by highlighting one sequence, right mouse click, and select the View Importance Measures option. The point estimates of all the importance measures are available from the first window.

   Compare your LOSP Sequence 2 importance measure results to;
   - Figure 29 for the Fussell-Vesely (FV) measures,
   - Figure 30 for the Risk Increase Ratio (RIR) importance measures,
   - Figure 31 for the uncertainty importance measures, and
   - Figure 32 for the Birnbaum importance measures.

   Compare your LOSP Sequence 3 importance measure results to;
   - Figure 33 for the Fussell-Vesely (FV) measures,
   - Figure 34 for the Risk Increase Ratio (RIR) importance measures,
   - Figure 35 for the uncertainty importance measures, and
   - Figure 36 for the Birnbaum importance measures.
Figure 29. LOSP Sequence 2 Fussell-Vesely importance measure results sorted by Fussell-Vesely (cut set truncation of 1E-13).
### Figure 30.
LOSP Sequence 2 interval importance measure results sorted by Risk Increase Ratio (cut set truncation of 1E-13).

<table>
<thead>
<tr>
<th>Name</th>
<th>Count</th>
<th>Prob</th>
<th>FV</th>
<th>RIR</th>
<th>RRR</th>
<th>RRR</th>
<th>RRI</th>
<th>RRI</th>
<th>RRI</th>
<th>Uncertainty</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S-DGN-FS-A</td>
<td>1</td>
<td>4.000E-03</td>
<td>1.584E-01</td>
<td>3.66E+01</td>
<td>1.183E+00</td>
<td>2.251E+00</td>
<td>2.242E+00</td>
<td>9.004E-03</td>
<td>6.750E-03</td>
<td>Diesel Generator A fails to start</td>
<td></td>
</tr>
<tr>
<td>E-MOV-CC-1</td>
<td>1</td>
<td>2.000E-04</td>
<td>7.920E-03</td>
<td>3.96E+01</td>
<td>1.008E+00</td>
<td>2.242E+00</td>
<td>2.242E+00</td>
<td>4.485E-04</td>
<td>1.107E-03</td>
<td>ECS Suction Isolation Valve fails to Open</td>
<td></td>
</tr>
<tr>
<td>E-PMP-FS-A</td>
<td>4</td>
<td>1.200E-03</td>
<td>1.332E-04</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.273E-03</td>
<td>7.543E-06</td>
<td>1.880E-05</td>
<td>ECS Pump A fails to start</td>
<td></td>
</tr>
<tr>
<td>E-PMP-FS-B</td>
<td>4</td>
<td>1.200E-03</td>
<td>1.332E-04</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.273E-03</td>
<td>7.543E-06</td>
<td>1.880E-05</td>
<td>ECS Pump B fails to start</td>
<td></td>
</tr>
<tr>
<td>E-MOV-CC-A</td>
<td>4</td>
<td>1.000E-03</td>
<td>1.110E-04</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.274E-03</td>
<td>6.266E-06</td>
<td>1.550E-05</td>
<td>ECS Train A Discharge MOV fails to Open</td>
<td></td>
</tr>
<tr>
<td>E-MOV-CC-B</td>
<td>4</td>
<td>1.000E-03</td>
<td>1.110E-04</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.274E-03</td>
<td>6.266E-06</td>
<td>1.550E-05</td>
<td>ECS Train B Discharge MOV fails to Open</td>
<td></td>
</tr>
<tr>
<td>E-PMP-FR-A</td>
<td>4</td>
<td>5.039E-04</td>
<td>5.595E-05</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.277E-03</td>
<td>3.167E-06</td>
<td>4.009E-06</td>
<td>ECS Pump A fails to run</td>
<td></td>
</tr>
<tr>
<td>E-PMP-FR-B</td>
<td>4</td>
<td>5.039E-04</td>
<td>5.595E-05</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.277E-03</td>
<td>3.167E-06</td>
<td>4.009E-06</td>
<td>ECS Pump B fails to run</td>
<td></td>
</tr>
<tr>
<td>E-CKV-CC-A</td>
<td>4</td>
<td>1.000E-04</td>
<td>1.110E-05</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.280E-03</td>
<td>6.280E-07</td>
<td>1.550E-06</td>
<td>ECS Train A Discharge Check Valve fails to Open</td>
<td></td>
</tr>
<tr>
<td>E-CKV-CC-B</td>
<td>4</td>
<td>1.000E-04</td>
<td>1.110E-05</td>
<td>1.10E+00</td>
<td>1.00E+00</td>
<td>6.230E-03</td>
<td>6.280E-03</td>
<td>6.280E-07</td>
<td>1.550E-06</td>
<td>ECS Train B Discharge Check Valve fails to Open</td>
<td></td>
</tr>
<tr>
<td>LOSP</td>
<td>19</td>
<td>2.300E+00</td>
<td>1.000E+00</td>
<td>4.34E+01</td>
<td>1.90E+03</td>
<td>2.525E+02</td>
<td>-3.283E-02</td>
<td>5.808E-02</td>
<td>1.434E-01</td>
<td>Loss of Offsite Power</td>
<td></td>
</tr>
</tbody>
</table>
Figure 31. LOSP Sequence 2 uncertainty importance measure results sorted by Uncertainty (cut set truncation of 1E-13).
Figure 32. LOSP Sequence 2 Birnbaum importance measure sorted by Birnbaum (cut set truncation of 1E-13).
Figure 33. LOSP Sequence 3 Fussell-Vesely importance measure results sorted by Fussell-Vesely (cut set truncation of 1E-13).
Figure 34. LOSP Sequence 3 Risk Increase Ratio importance measure results sorted by Risk Increase Ratio (cut set truncation of 1E-13).
Figure 35. LOSP Sequence 3 uncertainty importance measure results sorted by Uncertainty (cut set truncation of 1E-13).
Figure 36. LOSP Sequence 3 Birnbaum importance measure sorted by Birnbaum (cut set truncation of 1E-13).
3. Perform the importance analysis for both LOSP sequences combined by highlighting both sequences, right mouse click, and select View Importance Measures.

Compare your combined LOSP sequences importance measure results to:
Figure 37 for the Fussell-Vesely (FV) ratio importance measures,
Figure 38 for the Risk Increase Ratio (RIR) importance measures,
Figure 39 for the uncertainty importance measures, and
Figure 40 for the Birnbaum importance measures.

4. Looking at the importance analysis results for Sequence 2, Sequence 3, and Sequences 2 & 3 combined consider the following questions:

What is the quantified value saying for a particular component, such as E-PMP-FS-B or S-DGN-FS-B, with respect to each report?
What is the quantified value saying for a particular component, such as E-PMP-FS-B or S-DGN-FS-B, comparing across the reports?
What happens if the quantification method is changed (i.e., Min Cut versus Rare Event versus Min/Max)?
What happens if the truncation is increased (i.e., 1E-6, 1E-5, or 1E-3)?
What happens if truncation is lowered (i.e., 1E-15, 1E-20, or no truncation)?
How would you determine appropriate quantification method?
How would you determine appropriate truncation level?
Figure 37. LOSP Sequences 2 and 3 Fussell-Vesely ratio importance measure results sorted by Fussell-Vesely (cut set truncation of 1E-13).
Figure 38. LOSP Sequences 2 and 3 Risk Increase Ratio importance measure results sorted by RIR (cut set truncation of 1E-13).
Figure 39. LOSP Sequences 2 and 3 uncertainty importance measure results sorted by Uncertainty (cut set truncation of 1E-13).
Figure 40. LOSP Sequences 2 and 3 Birnbaum importance measure sorted by Birnbaum (cut set truncation of 1E-13).
13 Viewing Cut Sets

Workshop Objectives

The Viewing Cut Sets workshop accompanies Section 15 in the SAPHIRE Basics training manual. The workshop objective is to perform cut set viewing by using the “slice” option.

Workshop Instructions

We will use the DEMO project to view sequence cut sets for the LOSP event tree. We will use the slice feature to view only those cut sets that contain the event E-CKV-CC-A.

1. **Solve** for sequence cut sets (just LOSP, sequence 3). Solve the sequence cut sets with no truncation.

2. Click the **Cut Sets** button on the results screen and there should be a total of 314 cut sets with a total frequency (via the minimal cut set upper-bound) of 1.805E-03.
3. Now, “slice” the cut sets by clicking the “Slice” button and then the Events radio button.

4. In the list of “Cut Set Events,” check the E-CKV-CC-A checkbox.

5. Click the OK button. The cut sets shown should be displayed on screen:
6. Click the **Invert** button (to list the cut sets that did not meet the search criteria). The cut sets shown here should be displayed on screen:
Updates and Viewing the Nominal Case and Current Case

Workshop Objectives

The nominal case and current case workshop accompanies Sections 8 and 12 in the Basics training manual. The workshop objectives are to perform a nominal case update on fault tree results and event tree accident sequence results.

Workshop Instructions

We will move a copy of the current case results (for fault trees, event trees, and project uncertainty) into the nominal case. Prior to performing a nominal case update, make sure the basic events, fault trees and event tree contain the original workshop settings. These results will be considered our “Nominal case” or “Baseline” results which we want to retain as a permanent record for this project.

1. In the WKSP-1 project, highlight the CCS and ECS Fault Trees in the Fault Tree List Panel.

2. Right click on the highlighted fault trees and select Solve.

3. On the Solve Cut Sets for Group (FT) form, ensure that there are checks in the checkboxes Solve for Cut Sets, Update / Quantify Cut Sets, and Copy Cut Sets to Nominal Case. The first two are typically checked as a default. The Copy Cut Sets to Nominal Case defaults to its last solved state. Make sure that Clear Current Case is NOT checked.

4. Click Solve and the nominal case is updated to the “permanent” values.
5. Repeat Steps 1 through 4 for the Event Tree LOSP in the Event Tree List Panel with **Solve for Cut Sets**, **Apply Post-processing Rules**, **Update / Quantify Cut Sets**, and **Copy Cut Sets to Nominal Case** checked.

6. View the current and nominal cut sets for LOSP by right clicking on LOSP in the Event Tree List Panel and selecting **View Cut Sets**. The view is toggled by using the pull-down menu in the upper right corner of the cut set view form.
The purpose of the Clear Current Case checkbox is to completely eliminate cut sets and zero all data in the current case. This is a good way of “wiping the slate clean” before performing a new current case. When both Clear Current Case and Copy Cut Sets to Nominal Case are checked, the nominal case is wiped clean.

1. Solve LOSP with the **Clear Current Case** checked and **Copy Cut Sets to Nominal Case NOT** checked (the analyst can uncheck the Solve option, since no new cut sets are needed when clearing out the current and nominal case).

2. Investigate what happens to the cut sets with these solve options by viewing the current and nominal cut sets for LOSP by right clicking on LOSP in the Event Tree List Panel and selecting **View Cut Sets**.

3. Solve CCS with both **Clear Current Case** and **Copy Cut Sets to Nominal Case** checked

4. Investigate the effects of this set of solve options on the current and nominal cut sets for CCS by right clicking on CCS in the Fault Tree List Panel and selecting View Cut Sets.

Update the nominal case of the Fault Trees and Event Trees without the Clear Current Case selected (as per the first Section 16 workshop instructions) before proceeding to the next workshop section.
Fault Tree and Event Tree Sensitivity Analysis

Workshop Objectives

The Fault Tree and Event Tree Sensitivity Analysis workshop accompanies Section 17 in the Basics training manual. The workshop objectives are to perform fault tree and event tree sensitivity analyses involving basic event data changes made by creating Change Sets.

Workshop Instructions

First, we will create two Change Sets to increase the ECS and CCS pumps basic event failure probabilities. Then, we will utilize these change sets in order to modify current case data. Subsequent cut set solving will use this data and will be reflected in the results.

1. If the Change Sets List Panel is not visible in the left hand side Lists Panel window, open it by clicking on the Main Menu View → Change Sets.

2. To create a Change Set, double-click on New change set… to open the Change Set Editor.

3. You will make two Change Sets, one using only Singles changes and one using a mix of Singles and Class changes:

   CCS-PMP-INCREASE  CCS pumps FS and FR factor 10 increase - Single
   ECS-PMP-DECREASE  ECS pumps FS and FR factor 10 decrease - Mix
4. Name the first change set as above CCS-PMP-INCREASE and describe it. Then, click and drag Basic Event C-PMP-FR-A to the Singles window on the Change Set Editor and drop it there. Do the same for C-PMP-FR-B, C-PMP-FS-A, and C-PMP-FS-B. The Change Set Editor should now look as below:

![Change Set Editor](image)

Hint: all of the basic events can be highlighted and then dragged and dropped into the Singles form together.
5. Click on the event C-PMP-FR-A to expand its details and then on the Failure Model. The C-PMP-FR-A event will open in the Values to be Applied window for editing. Change the failure rate Lambda to 2.100E-04.

6. Repeat this process to change the following Basic Event Data:

   a. C-PMP-FR-B failure rate Lambda to 2.100E-04
   b. C-PMP-FS-A and C-PMP-FS-B Probability to 1.200E-02

   [Hint: multiple basic events can be highlighted and changed to the same values together (i.e., highlight both C-PMP-FS and change their probabilities.]
7. Click **OK** to save the CCS-PMP-INCREASE change set.

8. Start a **New change set**... as in Step 2 and name it:
   
   **ECS-PMP-DECREASE**  ECS pumps FS and FR factor 10 decrease – Mix

9. In the Singles window, repeat Steps 4-5 to add the Basic Events E-PMP-FR-A and E-PMP-FR-B and change their Lambda values to **2.10E-6**
10. Click on the Class tab at the top left of the Change Set Editor worksheet. From this screen you can select events to modify using mask criteria. For the ECS-PMP-DECREASE change set select **Use Class Change Set**, then **Name Mask**.

   a. The **Mask Combination** should read **Or**
   
   b. Enter **E-PMP-FS** in the **Match Value** column next to the **Name Mask**
      
      i. The asterisk is used as a wildcard symbol and will choose all Basic Events that start with E-PMP-FS

11. In the right-hand window, Click on **Failure Model** then change the Probability to **1.200E-04**
12. For these Change Sets to become active (affecting the current case values for the respective events), the desired change sets need to be “Marked.” Marking or Unmarking the change sets is accomplished by clicking on the checkbox next to the desired change set. A “Marked” change set will display a number next to the checkbox. Mark the CCS-PMP-INCREASE and ECS-PMP-DECREASE change sets (order does not matter as there is no overlap between the two).

Note on how the order of change sets work: Change sets will be applied according to their ordered marking (lower number change sets applied first) and subsequent change sets can overwrite a previous change (i.e., a basic event that is in two change sets will have the first change applied but then will be overwritten by the second change). Also, a change set can include both Class and Single Changes with the Class change being applied first and then individual changes applied second with an individual change overwriting if there is overlap from the class change.

13. Now use the change sets on the CCS and ECS fault trees by highlighting both fault trees in the Fault Tree List Panel, right click and select Solve. Use a truncation of 1.000E-08 and be sure that Copy Cut Sets to Nominal Case is NOT checked. (Close the solve option, by selecting Close.

14. With both fault trees highlighted, right click and select “View Summary Results.” The option will allow the analyst to view the current case results, nominal case results and the difference. The figure below shows the difference between the current case and nominal case results.
15. To view the cut sets for CCS fault tree, highlight the CCS fault tree, right click and select View Cut Sets.
16. The Current Case cut sets will display for the CCS fault tree. To compare the current case with the nominal case, use the pull-down menu at the top right of the cut sets view. The CCS Current and Nominal Cases are shown below.

<table>
<thead>
<tr>
<th>Prob/Freq</th>
<th>Total %</th>
<th>Cut Sets</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.601E-2</td>
<td>100</td>
<td>Displaying 28 Cut Sets (28 Original)</td>
</tr>
<tr>
<td>2.113E-2</td>
<td>81.25</td>
<td>S-DGN-FR-B</td>
</tr>
<tr>
<td>4.000E-3</td>
<td>15.38</td>
<td>S-DGN-FS-B</td>
</tr>
<tr>
<td>2.530E-4</td>
<td>0.96</td>
<td>C-PMP-FS-B,S-DGN-FR-A</td>
</tr>
<tr>
<td>2.000E-4</td>
<td>0.77</td>
<td>C-MOV-CC-1</td>
</tr>
<tr>
<td>1.440E-4</td>
<td>0.55</td>
<td>C-PMP-FS-A,C-PMP-FS-B</td>
</tr>
<tr>
<td>1.062E-4</td>
<td>0.41</td>
<td>C-PMP-FR-B,S-DGN-FR-A</td>
</tr>
<tr>
<td>6.033E-5</td>
<td>0.23</td>
<td>C-PMP-FS-B,C-PMP-FS-A</td>
</tr>
<tr>
<td>6.033E-5</td>
<td>0.23</td>
<td>C-PMP-FR-A,C-PMP-FS-B</td>
</tr>
<tr>
<td>4.800E-5</td>
<td>0.16</td>
<td>C-PMP-FS-B,S-DGN-FR-A</td>
</tr>
<tr>
<td>2.527E-5</td>
<td>0.10</td>
<td>C-PMP-FR-A,C-PMP-FR-B</td>
</tr>
<tr>
<td>2.113E-5</td>
<td>0.68</td>
<td>C-MOV-CC-1,B-S-DGN-FS-A</td>
</tr>
<tr>
<td>2.011E-5</td>
<td>0.08</td>
<td>C-PMP-FB-B,S-DGN-FR-A</td>
</tr>
<tr>
<td>1.200E-5</td>
<td>0.06</td>
<td>C-MOV-CC-1,B-C-PMP-FS-A</td>
</tr>
<tr>
<td>1.200E-5</td>
<td>0.05</td>
<td>C-MOV-CC-1,B-C-PMP-FS-A</td>
</tr>
<tr>
<td>5.027E-6</td>
<td>0.02</td>
<td>C-MOV-CC-1,B-C-PMP-FS-A</td>
</tr>
<tr>
<td>5.027E-6</td>
<td>0.02</td>
<td>C-MOV-CC-1,B-C-PMP-FS-A</td>
</tr>
<tr>
<td>4.000E-6</td>
<td>0.02</td>
<td>C-MOV-CC-1,B-C-PMP-FS-A</td>
</tr>
<tr>
<td>2.400E-6</td>
<td>0.01</td>
<td>S-TNK-FC-T1</td>
</tr>
<tr>
<td>2.113E-6</td>
<td>0.01</td>
<td>C-KV-CC-B,S-DGN-FR-A</td>
</tr>
<tr>
<td>1.200E-6</td>
<td>0.01</td>
<td>C-KV-CC-B,C-PMP-FS-A</td>
</tr>
<tr>
<td>1.000E-6</td>
<td>0.01</td>
<td>C-KV-CC-B,C-PMP-FS-A</td>
</tr>
<tr>
<td>1.000E-6</td>
<td>0.01</td>
<td>C-KV-CC-B,C-PMP-FS-A</td>
</tr>
<tr>
<td>5.027E-7</td>
<td>0.01</td>
<td>C-KV-CC-B,C-PMP-FS-A</td>
</tr>
<tr>
<td>2.527E-7</td>
<td>0.01</td>
<td>C-KV-CC-B,C-PMP-FS-A</td>
</tr>
<tr>
<td>4.000E-7</td>
<td>0.01</td>
<td>C-KV-CC-B,S-DGN-FS-A</td>
</tr>
<tr>
<td>1.000E-7</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
<tr>
<td>1.000E-7</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
<tr>
<td>1.000E-7</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
<tr>
<td>5.039E-8</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
<tr>
<td>5.039E-8</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
<tr>
<td>5.039E-8</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
<tr>
<td>1.000E-8</td>
<td>0.01</td>
<td>C-KV-CC-B,C-MOV-CC-1,B</td>
</tr>
</tbody>
</table>
17. Repeat steps 14 and 15 for the ECS Fault Tree. Results are shown below.
18. The same basic steps are used to apply and compare the change sets to nominal for Event Tree sequence cut sets:
   a. Mark the change sets
   b. Highlight the LOSP Event Tree in the Event Tree List Panel, right click and select Solve. Use a truncation of \(1.000E-13\) and be sure that Copy Cut Sets to Nominal Case is **NOT** checked.
   c. Right click on LOSP in the summary results (or if that is closed, on LOSP in the Event Tree List Panel) and select View Cut Sets.

19. The LOSP Sequence Cut Sets for the Current and Nominal Cases are presented below.
20. You can experiment with additional Change Sets if you wish. However, clear the current case as discussed in before beginning the next workshop session, you should return the data to the NOMINAL CASE state by unmarking the change sets.

21. You can experiment with additional Change Sets if you wish. If for some reason the Nominal Case was accidentally updated, be sure to unmark the change sets, solve and save to the nominal case as in Workshop section 16.
NOTES
Using Database Files

Workshop Objectives

The Using Database Files workshop accompanies Section 18 in the training manual. The workshop objectives are to copy fault tree, event tree, and basic event files from one project to a second project.

Workshop Instructions

Archiving a project:
When a project is archived, the complete project as it is currently is stored as a .zip file in a location of the user’s choosing. This .zip file will open as a duplicate project in SAPHIRE just as a .sra file does.

Archive your current WKSP-1 project:
1. Close any open windows within the project
2. Open main menu File → Archive Project → Full with Docs and choose a file name, location.
3. Then click Save.
MAR-D files:
Using the WKSP-1 project, a new fault tree is created from existing textual logic by extracting the ECS fault tree using MAR-D, editing the fault tree text, and then reloading the tree via MAR-D.

1. In the Fault Trees list panel, highlight the ECS fault tree.

2. Use the WKSP-1 project. Go to File → Load/Extract and select the Extract tab.

3. In the Extract tab of the Load/Extract dialogue:
   - Choose the Selected List Items (From main window lists) radio button in order to extract just the ECS fault tree logic file.
   - Expand the Fault Trees menu and place a check in the Logic checkbox.
   - Change the file in the Save As… textbox to end in ECS.MARD.

4. Once the file is output, use Windows Explorer to go into the WKSP-1 MAR-D project folder. The fault tree exported will be in a sub-folder to the MAR-D name given when the file was extracted (e.g., C:\Saphire8\WKSP-1\Mard\ECS_Subs).

5. To edit the ECS fault tree file, highlight the fault tree using Windows Explorer, double click the fault tree ECS.FTL, and then select Notepad (or any other Text editor).
The ECS logic should appear as:

\[
\text{WKSP-1, ECS =}
\]

\[
\text{SUP-DGN-B OR S-DGN-FR-B S-DGN-FS-B}
\]

\[
\text{SUP-DGN-A OR S-DGN-FR-A S-DGN-FS-A}
\]

\[
\text{ECS OR ECS-TRAINS ECS-SUPPLY}
\]

\[
\text{ECS-PUMP-B OR E-PMP-FR-B E-PMP-FS-B}
\]

\[
\text{ECS-TRAIN-B OR SUP-DGN-B ECS-PUMP-B E-CKV-CC-B E-MOV-CC-B}
\]

\[
\text{ECS-PUMP-A OR E-PMP-FR-A E-PMP-FS-A}
\]

\[
\text{ECS-TRAIN-A OR SUP-DGN-A ECS-PUMP-A E-CKV-CC-A E-MOV-CC-A}
\]

\[
\text{ECS-TRAINESS AND ECS-TRAIN-A ECS-PUMP-A}
\]

\[
\text{ECS-TRAIN-A OR SUP-DGN-A ECS-PUMP-A E-CKV-CC-A E-MOV-CC-A}
\]

\[
\text{ECS-TRAIN-A AND ECS-TRAIN-B ECS-TRAIN-A}
\]

\[
\text{ECS-TRAIN-A OR SUP-DGN-A ECS-PUMP-A E-CKV-CC-A E-MOV-CC-A}
\]

\[
\text{ECS-TRAIN-A AND ECS-TRAIN-B ECS-TRAIN-A}
\]

\[
\text{ECS-TRAIN-A OR SUP-DGN-A ECS-PUMP-A E-CKV-CC-A E-MOV-CC-A}
\]

\[
\text{ECS-MOV-1 OR SUP-DGN-A E-MOV-CC-1}
\]

\[
\text{ECS-SUPPLY OR ECS-MOV-1 S-TNK-FC-T1}
\]

5. Modify the logic for the ECS-TRAINS gate by changing the gate type from \textbf{AND} to \textbf{OR}.

6. Now, we want to call the modified fault tree XYZ (instead of ECS). Thus, perform a “search-and-replace” to change \textit{all} instances of ECS to XYZ. If you are using Notepad, choose the menu option “Search” and then “Replace” (accessible by \textbf{CTRL+H} shortcut). Specify the “Find what” input as \textbf{ECS} and “Replace with” as \textbf{XYZ}. Select the “Replace All” option.

7. Save the file as \textbf{XYZ.FTL}.

8. Exit the text editor and return to SAPHIRE. Go to the MAR-D \textit{load} option by using \textbf{File} → \textbf{Load/Extract} and select the \textbf{Load} tab, click the “Allow old formats” check box and then select the Open button and move to the subfolder containing the XYZ.FTL file and highlight this file and select Open.

9. Highlight this file (XYZ.FLT) and select Open. SAPHIRE will automatically select the file type check boxes. Now click the \textbf{Process} button and SAPHIRE will load in the new fault tree.

10. View the XYZ fault tree logic in the \textbf{Fault Trees} list panel and double clicking the XYZ fault tree or right click and selecting \textbf{Edit Logic} option. The logic for the XYZ fault tree should be identical to that shown below.